<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"> 
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="language" content="en, sv" />

<title>The Torch :   Courtside: Allow me to reintroduce myself</title>
<meta name="description" content="The Independent Student Newspaper of St. John&#039;s University" />
<meta name="generator" content="WordPress 4.6.1" />
<meta name="viewport" content="width=device-width,maximum-scale=1.0" />
<script type="text/javascript">
var addToHomeConfig = {
	expire: 10000,
	touchIcon: true
};
</script>

<link rel="stylesheet" href="http://www.torchonline.com/wp-content/themes/snoflex/tools/addtohome/add2home.css">
<script type="application/javascript" src="http://www.torchonline.com/wp-content/themes/snoflex/tools/addtohome/add2home.js"></script>
<meta name="apple-mobile-web-app-capable" content="yes">
<link rel="Shortcut Icon" href="http://www.torchonline.com/wp-content/uploads/2015/02/Torch_Logo1.jpg" type="image/x-icon" />
<link rel="alternate" type="application/rss+xml" title="The Torch RSS 2.0" href="http://www.torchonline.com/feed/" />
<link rel="alternate" type="text/xml" title="The Torch RSS .92" href="http://www.torchonline.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="The Torch Atom 0.3" href="http://www.torchonline.com/feed/atom/" />
<link rel="pingback" href="http://www.torchonline.com/xmlrpc.php" />

<link rel="stylesheet" media="screen" href="http://www.torchonline.com/wp-content/themes/snoflex/tools/superfish/css/superfish.css" />

<link rel="stylesheet" href="http://www.torchonline.com/wp-content/themes/snoflex/tools/flexslider/flexslider.css" type="text/css">
<script src="http://www.torchonline.com/wp-content/themes/snoflex/javascript/jquery.min.js"></script>
<script src="http://www.torchonline.com/wp-content/themes/snoflex/tools/flexslider/jquery.flexslider.js"></script>
<script src="http://www.torchonline.com/wp-content/themes/snoflex/javascript/jquery-visible.js"></script>

<script type="text/javascript" charset="utf-8">
$(window).load(function() {
    $('#topstories').flexslider({
		animationSpeed: 666,
    	animationLoop: true,
    	smoothHeight: true,
		slideshowSpeed: 5000,
		slideshow: true,
	 
		animation: "fade"
	    });
  });
$(window).load(function() {
    $('#sportspage').flexslider({
		animationSpeed: 666,
    	smoothHeight: true,
		slideshowSpeed: 5000,
		slideshow: true,
		animation: "slide",
		direction: "horizontal"
    });
  });


$(window).load(function() {
  // The slider being synced must be initialized first
  $('#carousel').flexslider({
    animation: 'slide',
    controlNav: false,
    directionNav: true,
    animationLoop: true,
    slideshow: false,
    itemWidth: 90,
    itemMargin: 5,
    touch: true,
    asNavFor: '#slideshow'
  });
   
  $('#slideshow').flexslider({
    animation: 'slide',
    smoothHeight: true,
    controlNav: false,
    directionNav: true,
    animationLoop: true,
    slideshow: false,
    touch: true,
    sync: "#carousel"
  });
});
</script>

<script type="text/javascript" src="http://www.torchonline.com/wp-content/themes/snoflex/tools/superfish/js/hoverIntent.js"></script>
<script type="text/javascript" src="http://www.torchonline.com/wp-content/themes/snoflex/tools/superfish/js/superfish.js"></script>
<script type="text/javascript" src="http://www.torchonline.com/wp-content/themes/snoflex/tools/superfish/js/supersubs.js"></script> 
<script type="text/javascript" src="http://www.torchonline.com/wp-content/themes/snoflex/javascript/jquery-scrolltofixed-min.js"></script> 
<script type="text/javascript" src="http://www.torchonline.com/wp-content/themes/snoflex/javascript/remodal.min.js"></script> 
 <link rel="stylesheet" href="http://www.torchonline.com/wp-content/themes/snoflex/javascript/remodal.css"> 
 <link rel="stylesheet" href="http://www.torchonline.com/wp-content/themes/snoflex/javascript/remodal-default-theme.css"> 
<script> 
 
    $(document).ready(function(){ 
        $("ul.sf-menu").supersubs({ 
            minWidth:    12,   // minimum width of sub-menus in em units 
            maxWidth:    40,   // maximum width of sub-menus in em units 
            extraWidth:  1     // extra width can ensure lines don't sometimes turn over 
        }).superfish({
    		delay:      200,     
        	speed:		'fast'
        });  // call supersubs first, then superfish, so that subs are 
                         // not display:none when measuring. Call before initialising 
                         // containing tabs for same reason. 
			var windowWidth;
        	windowWidth= $(window).width();
        	$( window ).resize(function() {
           		windowWidth = $(window).width();
        	});

        	$('.sf-menu').superfish({
            	onBeforeShow : function (){                 
            		if(!this.is('.sf-menu>li>ul')){
            	        var subMenuWidth = $(this).width();
            	        var parentLi = $(this).parent();                    
            	        var parentWidth = parentLi.width() -8 ;
            	        var subMenuRight = parentLi.offset().left + parentWidth + subMenuWidth;
            	        if(subMenuRight > windowWidth){
            	           	$(this).css('left','auto');
            	            $(this).css('right', parentWidth+'px');
            	        } else {
            	           	$(this).css('right','auto');
            	           	parentWidth +=8;
            	            $(this).css('left', parentWidth+'px');
            	        }
            	    }
            	}
        	});
    }); 
jQuery().ready(function( jQuery ) {
    jQuery(".wp-caption").width(function() {
        return jQuery('img', this).width();
    });
});

</script>
<script type="text/javascript" src="http://www.torchonline.com/wp-content/themes/snoflex/javascript/jquery.cycle.all.min.js"></script>

<script src="http://www.torchonline.com/wp-content/themes/snoflex/javascript/jcarousellite_1.0.1c4.js" type="text/javascript"></script>  

<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Torch &raquo; Courtside: Allow me to reintroduce myself Comments Feed" href="http://www.torchonline.com/sports/2016/11/22/courtside-allow-me-to-reintroduce-myself/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.torchonline.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.6.1"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='prettyphoto-css'  href='http://www.torchonline.com/wp-content/plugins/prettyphoto-media/css/prettyPhoto.css?ver=3.1.4' type='text/css' media='screen' />
<link rel='stylesheet' id='farbtastic-css'  href='http://www.torchonline.com/wp-admin/css/farbtastic.min.css?ver=1.3u1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='http://www.torchonline.com/wp-includes/css/dashicons.min.css?ver=4.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='http://www.torchonline.com/wp-includes/js/thickbox/thickbox.css?ver=4.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='http://www.torchonline.com/wp-content/plugins/menu-icons/includes/library/icon-picker/css/types/font-awesome.min.css?ver=4.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='foundation-icons-css'  href='http://www.torchonline.com/wp-content/plugins/menu-icons/includes/library/icon-picker/css/types/foundation-icons.min.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='menu-icons-extra-css'  href='http://www.torchonline.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.10.1' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.torchonline.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.5' type='text/css' media='all' />
<link rel='stylesheet' id='sb_instagram_styles-css'  href='http://www.torchonline.com/wp-content/plugins/instagram-feed/css/sb-instagram.min.css?ver=1.4.7' type='text/css' media='all' />
<link rel='stylesheet' id='sb_instagram_icons-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.6.3/css/font-awesome.min.css?ver=4.6.3' type='text/css' media='all' />
<link rel='stylesheet' id='my-calendar-reset-css'  href='http://www.torchonline.com/wp-content/plugins/my-calendar/css/reset.css?ver=4.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='my-calendar-style-css'  href='http://www.torchonline.com/wp-content/plugins/my-calendar/styles/my-calendar.css?ver=4.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='http://www.torchonline.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.1' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background: #d8e1eb;
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='googleFonts-css'  href='http://fonts.googleapis.com/css?family=Ovo%7COvo%7COxygen%7COxygen%7CPlayfair+Display%7CPT+Sans%7CMerriweather%7COxygen%7COxygen%7CRoboto%7CGilda+Display&#038;ver=4.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelementjs-styles-css'  href='http://www.torchonline.com/wp-content/plugins/media-element-html5-video-and-audio-player/mediaelement/mediaelementplayer.css?ver=4.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-paginate-css'  href='http://www.torchonline.com/wp-content/plugins/wp-paginate/wp-paginate.css?ver=1.3.1' type='text/css' media='screen' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v5.5.2 - Universal enabled - https://www.monsterinsights.com/ -->
<script type="text/javascript">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-59055616-1', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('require', 'displayfeatures');
	__gaTracker('send','pageview');

</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='http://www.torchonline.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.torchonline.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.torchonline.com/wp-content/plugins/media-element-html5-video-and-audio-player/mediaelement/mediaelement-and-player.min.js?ver=2.1.3'></script>
<link rel='https://api.w.org/' href='http://www.torchonline.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.torchonline.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.torchonline.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Student Affairs releases letter following the presidential election' href='http://www.torchonline.com/news/2016/11/21/student-affairs-releases-letter-following-the-presidential-election/' />
<link rel='next' title='Courtside: Brooklyn&#8217;s finest ready to conquer Queens' href='http://www.torchonline.com/sports/2016/11/22/brooklyns-finest-ready-to-conquer-queens/' />
<meta name="generator" content="WordPress 4.6.1" />
<link rel='shortlink' href='http://www.torchonline.com/?p=2232799' />
<link rel="alternate" type="application/json+oembed" href="http://www.torchonline.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.torchonline.com%2Fsports%2F2016%2F11%2F22%2Fcourtside-allow-me-to-reintroduce-myself%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.torchonline.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.torchonline.com%2Fsports%2F2016%2F11%2F22%2Fcourtside-allow-me-to-reintroduce-myself%2F&#038;format=xml" />

<style type="text/css">
<!--
/* Styles by My Calendar - Joseph C Dolson http://www.joedolson.com/ */

.mc-event-visible {
display: block!important;
}
-->
</style>
<script type='text/javascript'>
	jQuery('html').addClass('mcjs');
	jQuery(document).ready( function($) { $('html').removeClass('mcjs') } );
</script>
    <style type="text/css" media="screen">
          div.printfriendly a, div.printfriendly a:link, div.printfriendly a:hover, div.printfriendly a:visited {
            text-decoration: none;
            border: none;
          }
    </style>
           <style type="text/css" media="screen">
          div.printfriendly {
            margin: 12px 12px 12px 12px;
          }
          div.printfriendly a, div.printfriendly a:link, div.printfriendly a:visited {
            font-size: 14px;
            color: #6D9F00;
            vertical-align: bottom;
          }
          .printfriendly a {
            box-shadow:none;
          }
          .printfriendly a:hover {
            cursor: pointer;
          }
          .printfriendly a img  {
            border: none;
            padding:0;
            margin-right: 6px;
            box-shadow: none;
            -webkit-box-shadow: none;
            -moz-box-shadow: none;
          }
          .printfriendly a span{
            vertical-align: bottom;
          }
          .pf-alignleft {
            float: left;
          }
          .pf-alignright {
            float: right;
          }
          div.pf-aligncenter {
            display: block;
            margin-left: auto;
            margin-right: auto;
            text-align: center;
          }
        </style>
        <style type="text/css" media="print">
          .printfriendly {
            display: none;
          }
        </style>

	<meta property="og:title" content="Courtside: Allow me to reintroduce myself" />
	<meta property="og:type" content="article" />
	<meta name="author" content="Troy Mauriello" />
	<meta property="og:url" content="http://www.torchonline.com/sports/2016/11/22/courtside-allow-me-to-reintroduce-myself/" />
	<meta property="og:image" content="http://www.torchonline.com/wp-content/uploads/2016/11/lovett2-600x900.jpeg" />
	<meta property="og:image:width" content="600" />
	<meta property="og:image:height" content="900" />
	<meta property="og:site_name" content="The Torch" />
	<meta property="og:description"
          content="It’s a debut that can’t come soon enough. On Nov. 11 when the Johnnies open their regular season against Bethune Cookman, it will have been one year, five months and three weeks since Marcus Lovett Jr. committed to play for St. John’s. Red Storm fans, players and coaches have been waiting anxiously throughout that period..." />
	<meta property="article:section" content="Basketball" />
	<meta property="article:tag" content="Chris Mullin,Marcus LoVett,SJU Basketball,SJUBB,St. John's Basketball" />
<!-- End of Facebook Meta Tags -->
<link rel='canonical' href='http://www.torchonline.com/sports/2016/11/22/courtside-allow-me-to-reintroduce-myself/' />
<!-- wp thread comment 1.4.9.4.002 -->
<style type="text/css" media="screen">

.editComment, .editableComment, .textComment{
	display: inline;
}
.comment-childs{
	border: 1px solid #999;
	margin: 5px 2px 2px 4px;
	padding: 4px 2px 2px 4px;
	background-color: white;
}
.chalt{
	background-color: #E2E2E2;
}
#newcomment{
	border:1px dashed #777;width:90%;
}
#newcommentsubmit{
	color:red;
}
.adminreplycomment{
	border:1px dashed #777;
	width:99%;
	margin:4px;
	padding:4px;
}
.mvccls{
	color: #999;
}
			
</style>

<script>
	$(document).ready(function() {
		var wpadminbar = $('#wpadminbar').outerHeight();
		if (wpadminbar == null) { var wpadminbar = 0; }
		if ($('#wpadminbar').is(":hidden")) { wpadminbar = 0; }

	
			
		
		
	
	});
</script>


<style type="text/css" media="screen"><!-- @import url( http://www.torchonline.com/wp-content/themes/snoflex/style.css ); --></style>

<style type="text/css" media="screen">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</style>
</head>

<body><ul id="menu"><li>	<form method="get" id="searchform" action="http://www.torchonline.com/">
			<label for="s" class="assistive-text">Search</label>
			<input type="text" class="field" name="s" id="s" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit" value="Search" />
		</form>
	</li><div class="clear"></div><li><a href="http://www.torchonline.com">Home</a></li><li><a href="http://www.torchonline.com/about/">About</a></li><li><a href="http://www.torchonline.com/about/staff/">Staff</a></li><li><a href="http://www.torchonline.com/advertising/">Advertising</a></li><li><a href="http://www.torchonline.com/pdfissues/">Full Issues</a></li><li><a href="http://www.torchonline.com/subscriptions/">Subscriptions</a></li></ul><div id="wrap"><div id="mobile-menu"><div class="sitetitle"><div class="headersmall" style="display:none"><a href="http://www.torchonline.com"><img src="http://www.torchonline.com/wp-content/uploads/2013/08/Screen-shot-2013-07-26-at-10.37.04-AM1.png" class="headerimage" alt="The Independent Student Newspaper of St. John&#039;s University" /></a></div><div class="headermedium" style="display:none"><a href="http://www.torchonline.com"><img src="http://www.torchonline.com/wp-content/uploads/2013/08/Screen-shot-2013-07-26-at-10.37.04-AM1.png" class="headerimage" alt="The Independent Student Newspaper of St. John&#039;s University" /></a></div><div class="headerlarge"><a href="http://www.torchonline.com"><img src="http://www.torchonline.com/wp-content/uploads/2013/08/Screen-shot-2013-07-26-at-10.37.04-AM1.png" class="headerimage" alt="The Independent Student Newspaper of St. John&#039;s University" /></a></div></div><div id="mobile_menu_icon"><div class="mobile_menu_icon_bar"></div><div class="mobile_menu_icon_bar"></div><div class="mobile_menu_icon_bar"></div></div><div class="clear"></div><div class="clear"></div></div><div class="navbarwrap"><div class="navbarcontainer"><div id="navbar"><div id="navbarbackground"><div id="menu-a-menu"><div class="menu-top-menu-container"><ul id="menu-top-menu" class="sf-menu sno-top-menu"><li id="menu-item-206" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-206"><a href="http://www.torchonline.com">Home</a></li>
<li id="menu-item-208" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208"><a href="http://www.torchonline.com/about/">About</a></li>
<li id="menu-item-210" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-210"><a href="http://www.torchonline.com/about/staff/">Staff</a></li>
<li id="menu-item-2222954" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2222954"><a href="http://www.torchonline.com/advertising/">Advertising</a></li>
<li id="menu-item-2228097" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2228097"><a href="http://www.torchonline.com/pdfissues/">Full Issues</a></li>
<li id="menu-item-2228108" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2228108"><a href="http://www.torchonline.com/subscriptions/">Subscriptions</a></li>
</ul></div></div><ul id='menu-more-top' class='sf-menu sf-js-enabled sf-shadow' style='display:none'><li id="menu-more-item-top" style="float:left;"><a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"> »</span></a>
								<ul id="add-more-top" class="sub-menu"></ul>
								</li>
							</ul></div></div></div></div><div class="clear"></div><script type="text/javascript">
					$(document).ready(function() {
						
						if ($( window).width() < 980) { return; }

						resizeMenuTop();
					})
					$(window).load(function() {
						
						if ($( window).width() < 980) { return; }

						resizeMenuTop();
					})
					
					function resizeMenuTop() {
						
						if ($( window).width() < 980) { return; }

						var moreWidthTop = 0; var menubufferTop = 0; var minilogoTop = 0;

						if ($('#menu-more-top').is(':visible')) { moreWidthTop = $('#menu-more-top').width(); }			
																		
						var MenuTopWidth = $('#navbarbackground').width() - 10;

						if ($('#menu-a-menu').width() + menubufferTop + minilogoTop + moreWidthTop > MenuTopWidth) 
						{ 
							$('.sno-top-menu > li:last-child').addClass('sub-menu'); 
							$('.sno-top-menu > li:last-child').appendTo('#add-more-top'); 
							if ($('#menu-more-top').is(':hidden')) { $('#menu-more-top').css({display: "block"}); }			
							resizeMenuTop(); 
						} 
						 
					}
					$( window ).scroll(function() {
						
						if ($( window).width() < 980) { return; }

						resizeMenuTop();
					});
            		$( window ).resize(function() { 
	            		
             	   		if ($( window).width() > 980) { resizeMenuTop(); };
            		});   
 				</script><div class="headerwrap"><div id="header" style="position:relative;"><div class="headerlarge"><a href="http://www.torchonline.com"><img src="http://www.torchonline.com/wp-content/uploads/2013/08/Screen-shot-2013-07-26-at-10.37.04-AM1.png" class="headerimage" alt="The Independent Student Newspaper of St. John&#039;s University" /></a></div><div class="header-icons"><style>.topnavbarleft { padding: 0px; width:auto; }</style><div class="social-spacer"></div></div><div class="header-search">	<form method="get" id="searchform" action="http://www.torchonline.com/">
			<label for="s" class="assistive-text">Search</label>
			<input type="text" class="field" name="s" id="s" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit" value="Search" />
		</form>
	</div></div></div><div class="bottom-menu"><div class="subnavbarwrap"><div class="subnavbarcontainer"><div id="subnavbar"><div id="subnavbarbackground"><div id="menu-b-menu"><div class="menu-bottom-menu-container"><ul id="menu-bottom-menu" class="sf-menu sno-bottom-menu"><li id="menu-item-211" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-211"><a href="http://www.torchonline.com/category/news/">News</a></li>
<li id="menu-item-2229873" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2229873"><a href="http://www.torchonline.com/category/sports/">Sports</a></li>
<li id="menu-item-213" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-213"><a href="http://www.torchonline.com/category/features/">Features</a></li>
<li id="menu-item-2229874" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2229874"><a href="http://www.torchonline.com/category/entertainment/">Entertainment</a></li>
<li id="menu-item-212" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-212"><a href="http://www.torchonline.com/category/opinion/">Opinion</a></li>
<li id="menu-item-2232265" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2232265"><a href="http://www.torchonline.com/category/election-2016/">Election 2016</a></li>
</ul></div></div><ul id='menu-more-bottom' class='sf-menu sf-js-enabled sf-shadow' style='display:none'><li id="menu-more-item-bottom" style="float:left;"><a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"> »</span></a>
						<ul id="add-more-bottom" class="sub-menu"></ul>
						</li>
					</ul></div></div></div></div></div><div class="clear"></div><script type="text/javascript">
					$(document).ready(function() {
						if ($( window).width() < 980) { return; }
						resizeMenuBottom();
					})
					$(window).load(function() {
						if ($( window).width() < 980) { return; }
						resizeMenuBottom();
					})
					
					function resizeMenuBottom() {
						if ($( window).width() < 980) { return; }
						var moreWidth = 0; var menubuffer = 0; var minilogo = 0;
						if ($('#menu-more-bottom').is(':visible')) { moreWidth = $('#menu-more-bottom').width(); }			
																		var MenuBottomWidth = $('#subnavbarbackground').width() - 10;
						if (($('#menu-b-menu').width() + menubuffer + minilogo + moreWidth) > MenuBottomWidth) 
						{ 
							$('.sno-bottom-menu > li:last-child').addClass('sub-menu'); 
							$('.sno-bottom-menu > li:last-child').appendTo('#add-more-bottom'); 
							if ($('#menu-more-bottom').is(':hidden')) { $('#menu-more-bottom').css({display: "block"}); }			
							resizeMenuBottom(); 
						} 
						 
					}
					$( window ).scroll(function() {
						if ($( window).width() < 980) { return; }
						resizeMenuBottom();
					
					});
            		$( window ).resize(function() { 
             	   		if ($( window).width() > 980) { resizeMenuBottom(); };
            		});   
 				</script>				<script type="text/javascript">
					$(function() {
						$(".newsticker3-jcarousellite").jCarouselLite({
        					vertical: true,
        					visible: 1,
        					auto:3000,
        					speed:1300    					});
					});
				</script><div id="fullwrap" style="position:relative;"><div class="innerbackgroundwrap"><div class="innerbackground"><div id="classic_story"><div id="content"><div id="contentleft"><div class="postarea"><h1 class="storyheadline">Courtside: Allow me to reintroduce myself</h1><div class="clear"></div><div class="permalinkphotobox"><div class="photowrap"><a rel="prettyPhoto[1]" href="http://www.torchonline.com/wp-content/uploads/2016/11/lovett2-600x900.jpeg" title="Marcus LoVett looks to make an impact in his first season on the court at St. John's (Photo Credit: RedStormSports.com)."><img src="http://www.torchonline.com/wp-content/uploads/2016/11/lovett2-600x900.jpeg" style="width:100%" class="catboxphoto" /></a></div><div class="clear"></div><div class="captionboxmit"><p class="photocaption">Marcus LoVett looks to make an impact in his first season on the court at St. John's (Photo Credit: RedStormSports.com).</p></div></div><div class="storydetails"><p><span class="storybyline"> <a href="http://www.torchonline.com/about/staff/?writer=Troy%20Mauriello">Troy Mauriello</a>, Co-Sports Editor</span><br /><span class="storydate">November 22, 2016</span><br /><span class="storycategory">Filed under <a href="http://www.torchonline.com/category/basketball/" rel="category tag">Basketball</a>, <a href="http://www.torchonline.com/category/mens-basketball/" rel="category tag">Men's Basketball</a>, <a href="http://www.torchonline.com/category/sports/" rel="category tag">Sports</a>, <a href="http://www.torchonline.com/category/sports-scroll/" rel="category tag">Sports Scroll</a></span></p></div><div class="sharing sharing-top"><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.torchonline.com%2Fsports%2F2016%2F11%2F22%2Fcourtside-allow-me-to-reintroduce-myself%2F" title="Share on Facebook" target="_blank"><div class="sharing-icon sharing-mobile sno-facebook dashicons dashicons-facebook-alt sno-dark sharing-mobile-hide"></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=Courtside%3A+Allow+me+to+reintroduce+myself&amp;url=http%3A%2F%2Fwww.torchonline.com%2F%3Fp%3D2232799" title="Tweet This Story" target="_blank"><div class="sharing-icon sharing-mobile sno-twitter dashicons dashicons-twitter sno-dark sharing-mobile-hide"></div></a><a data-remodal-target="modal"><div class="sharing-icon sno-email dashicons dashicons-email-alt sno-dark sharing-mobile-hide"></div></a></div>			<script type="text/javascript">
				$(document).ready(function() {
					$(function(){
						$('.modal-share').click(function() {
							var inst = $('[data-remodal-id=modal-share]').remodal();
							inst.open();

							var sharestoryid = '2232799';

							$.ajax({
	                			url:"/wp-admin/admin-ajax.php",
								type:'POST',
								data:'action=sharestory&sharestoryid=' + sharestoryid,
								success:function(results)
	            					{ $("#suggestedstories").replaceWith(results); }
	           				});

						});
										
					});
				});
			</script>

			<div class="remodal" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false">
  				<button data-remodal-action="close" class="remodal-close"></button>
  				<div id="suggestedstories">
  				<h1>Hang on for a minute...we're trying to find some more stories you might like.</h1>
  				<form method="post" action="">

  				<br />
  				<button data-remodal-action="cancel" class="remodal-cancel">Close</button>

  				</form>
  				</div>
			</div>

					<div class="remodal" data-remodal-id="modal" data-remodal-options="hashTracking: false, closeOnConfirm: false">
  				<button data-remodal-action="close" class="remodal-close"></button>
  				<div id="emailstoryform">
  				<h1>Email This Story</h1>
  				<form method="post" action="">
  				<input type="text" id="email_to_Above" name="email_to_Above" class="sno_email_fields" placeholder="Send email to this address"><br />
  				<input type="text" id="email_from_Above" name="email_from_Above" class="sno_email_fields" placeholder="Enter Your Name"><br />
  				<textarea rows="4" id="email_comment_Above" name="email_comment_Above" class="sno_email_fields" placeholder="Add a comment here (optional)."></textarea><br />
  				<input type="text" id="human_Above" name="human_Above" class="sno_email_fields" placeholder="What's 7 + 1?"><br />

  				<br />
  				<button id="submit_email_Above" data-remodal-action="confirm" class="remodal-confirm">Send Email</button>
  				<button data-remodal-action="cancel" class="remodal-cancel">Cancel</button>
  				<input type="hidden" id="sno_email_submission_form" name="sno_email_submission_form" value="d8a60ab200" /><input type="hidden" name="_wp_http_referer" value="/sports/2016/11/22/courtside-allow-me-to-reintroduce-myself/" />
  				</form>
  				</div>
			</div>
										<script>
								$(document).ready(function() {

								$(function(){
           							$('#submit_email_Above').click(function(){
											var storyid = '2232799';
											var datastring = '';
											if ($("#email_to_Above").length > 0){
												var email_to = $('input[name=email_to_Above]');
												datastring += '&email_to=' + encodeURIComponent(email_to.val());
       										}

											if ($("#email_from_Above").length > 0){
												var email_from = $('input[name=email_from_Above]');
												datastring += '&email_from=' + encodeURIComponent(email_from.val());
       										}

											if ($("#email_comment_Above").length > 0){
												var email_comment = $('textarea[name=email_comment_Above]');
												datastring += '&email_comment=' + encodeURIComponent(email_comment.val());
       										}

											if ($("#human_Above").length > 0){
												var human = $('input[name=human_Above]');
												datastring += '&human=' + encodeURIComponent(human.val());
       										}
       										
	   										datastring += '&humanity=' + 8;

       										var verification = $('input[name=sno_email_submission_form]');
	   										datastring += '&verification=' + verification.val();
       										
										//	var parentid = '';
               							$.ajax({
                				            url:"/wp-admin/admin-ajax.php",
                				            type:'POST',
                				            data:'action=emailstory&storyid=' + storyid + datastring,
 	            				            success:function(results)
	            				            { $("#emailstoryform").replaceWith(results); }
	           				    	  	});
	         						});
								});
								});

							</script>

			<div class="pf-content"><p id='graph1'><span style="font-weight: 400;">It’s a debut that can’t come soon enough. </span></p>
<p id='graph2'><span style="font-weight: 400;">On Nov. 11 when the Johnnies open their regular season against Bethune Cookman, it will have been one year, five months and three weeks since Marcus Lovett Jr. committed to play for St. John’s. Red Storm fans, players and coaches have been waiting anxiously throughout that period for LoVett to make his St. John’s debut.</span></p>
<p id='graph3'><span style="font-weight: 400;">After he was ruled a partial qualifier by the NCAA around this time last year, LoVett had to spend what would have been his freshman season watching on the sidelines as his young teammates struggled to an 8-24 overall record.</span></p>
<p id='graph4'><span style="font-weight: 400;">Now as a redshirt freshman heading into this year, LoVett does not seem to be phased by any of the expectations for his highly anticipated first appearance in red and white.</span></p>
<p id='graph5'><span style="font-weight: 400;">“I don’t look at is as pressure, to me honestly,” he said at St. John’s Media Day on Oct. 27. “I just look at it as going out there to do what I do best, every day, which is play the game. Go out there not thinking that this is pressure at all, just going out there to play basketball.”</span></p>
<p id='graph6'><span style="font-weight: 400;">Coming out of Morgan Park High School in Chicago, LoVett was a consensus four-star recruit across the board in the Class of 2015. However he spent time at four different high schools throughout his career, excelling and becoming a team leader at each stop along the way.</span></p>
<p id='graph7'><span style="font-weight: 400;">He’ll hope to transfer those leadership qualities into his first season on the court at St. John’s, where he’ll likely step in as the Red Storm’s starting point guard on opening night.</span></p>
<p id='graph8'><span style="font-weight: 400;">“Of course it’s a different experience,” LoVett said on the conversion from high school to college. “You’re playing with better players, guys that are real athletic and can do everything. It’s definitely different from high school to college, but it’s a great journey and transition and I’ve been enjoying it.”</span></p>
<p id='graph9'><span style="font-weight: 400;">Making that transition a tad easier for LoVett will be the year that he spent examining on the sidelines in 2015-16. Red Storm fans can only hope that “lost” season for the talented guard ends up being a blessing in disguise, and to this point, it appears that may be the case.</span></p>
<p id='graph10'><span style="font-weight: 400;">LoVett is already exhibiting incredible maturity levels not usually seen from 20-year-old point guards making their collegiate debut. He has described himself as the “quarterback” of the Red Storm’s offense this year and can be seen constantly pushing his teammates to get better in practice.</span></p>
<p id='graph11'><span style="font-weight: 400;">“I’m basically the quarterback of this team, so I’ve got to direct guys in certain positions and make sure they succeed,” LoVett said. “So that’s pretty much my main concern, putting people in the right positions to do good.” </span></p>
<p id='graph12'><span style="font-weight: 400;">While many of his teammates were gaining in-game experience and learning lessons on the fly last year, LoVett can use almost a full year of observations from the sideline to help guide him on the court in 2016-17</span></p>
<p id='graph13'><span style="font-weight: 400;">“Just being able to watch [last year], not being able to play, just knowing where I can help out in every aspect. Last year wasn’t so great for us but it was a learning experience for everybody, everybody on the team, so it was great,” he said. </span></p>
<p id='graph14'><span style="font-weight: 400;">Also joining LoVett in his first season on the court at St. John’s will be another four-star recruit in Shamorie Ponds. Those two, coupled with last season’s leading scorer, Federico Mussini, turn a once weak Red Storm backcourt last season into one of the team’s biggest strengths heading into this year. </span></p>
<p id='graph15'><span style="font-weight: 400;">“It’s great, [Shamorie and I] work well together, we always find each other at different positions and places on the court,” LoVett said. “[Him, Federico and myself] always work well together so it’s going to be great for us to actually be on the court together and play on the same team.”</span></p>
<p id='graph16'><span style="font-weight: 400;">Head Coach Chris Mullin was also high on his pair of four-star guards at the team’s media day. He described LoVett and Ponds as “gym rats” who “love all the different aspects of the game.”</span></p>
<p id='graph17'><span style="font-weight: 400;">“He’s got so many different skills, I think probably the biggest is speed and his ball handling,” Mullin said about LoVett. “He’s really unselfish, very meticulous in his preparation, he wants to execute exactly, he wants to be efficient.”</span></p>
<p id='graph18'><span style="font-weight: 400;">When asked if LoVett reminded him of any players that he played against throughout college or in the NBA, Mullin brought up that LoVett bears a resemblance to Kenny Anderson, a fellow southpaw guard who spent over 15 years playing professionally.</span></p>
<p id='graph19'><span style="font-weight: 400;">After seeing some of his highlight videos posted to social media, Red Storm fans may liken LoVett to recent NBA Hall of Fame inductee Allen Iverson, who, like LoVett, stands only six feet tall yet used his craftiness to excel in the league.</span></p>
<p id='graph20'><span style="font-weight: 400;">“Guys like Marcus, years ago they were too small. It seems like those guys are really starting to have a big impact on the game at every level now,” said Mullin. “Maybe small in stature but within the last five to 10 years those guys have been having a big impact.”</span></p>
<p id='graph21'><span style="font-weight: 400;">It’s clear that the feeling of respect is mutual between Mullin and his incoming point guard. LoVett noted that the Red Storm head coach was one of the people who helped him out the most after the disappointing verdict on his eligibility came down last November.</span></p>
<p id='graph22'><span style="font-weight: 400;">“He’s just always there with positive words. And it helped a lot, just making sure that I was never falling off or thinking of any negative thoughts that I had went through,” LoVett said.</span></p>
<p id='graph23'><span style="font-weight: 400;">Those positive vibes will hopefully continue for the Johnnies in the next few months, where they’ll try to improve upon a forgettable 2015-16 campaign with a nice blend of experienced sophomores and new incoming faces. </span></p>
<p id='graph24'><span style="font-weight: 400;">LoVett will be expected to be one of those new faces that carry the load for St. John’s this year, a task that he is more than willing to take on.</span></p>
<p id='graph25'><span style="font-weight: 400;">“This is the big year for us, to turn the program around. Just coming from last year’s team, how we did, I think this year’s team is real special,” he said. </span></p>
<div class="printfriendly pf-alignleft"><a href="#" rel="nofollow" onclick="window.print(); return false;" class="noslimstat"><img style="border:none;-webkit-box-shadow:none; box-shadow:none;" src="http://cdn.printfriendly.com/button-print-grnw20.png" alt="Print Friendly" /></a></div></div></p><div id="story_bottom"></div><div class="clear"></div><div class="postmeta"><p><span class="tags sno">Tags: <a href="http://www.torchonline.com/tag/chris-mullin/" rel="tag">Chris Mullin</a>, <a href="http://www.torchonline.com/tag/marcus-lovett/" rel="tag">Marcus LoVett</a>, <a href="http://www.torchonline.com/tag/sju-basketball/" rel="tag">SJU Basketball</a>, <a href="http://www.torchonline.com/tag/sjubb/" rel="tag">SJUBB</a>, <a href="http://www.torchonline.com/tag/st-johns-basketball/" rel="tag">St. John's Basketball</a></span></p></div></div></div><div id="sidebar"><div class="widgetwrap sno-animate">			<div class="widgetbody3" >			<div class="advertisementwrap" style="margin:0px auto;max-width:100%">
				<a target="_blank" href="/subscriptions"><img src="http://www.torchonline.com/wp-content/uploads/2016/09/subscribe.jpg"  class="centered" style="max-width:100%" /></a>
			</div>
			</div><div class="clear"></div></div><div class="widgetwrap sno-animate">			<div class="widgetbody3" >			<div class="advertisementwrap" style="margin:0px auto;max-width:100%">
				<a target="_blank" href="http://www.torchonline.com/?page_id=2231836&preview=true"><img src="http://www.torchonline.com/wp-content/uploads/2016/08/pitchtous-1.jpg"  class="centered" style="max-width:100%" /></a>
			</div>
			</div><div class="clear"></div></div><div style="clear:both"></div><div class="widgetwrap sno-animate"><div><div></div><div class="titlewrap"><h2><span class='twitterwidget twitterwidget-title'>Twitter </span></h2></div><div class="widgetbody"><div class="twitter-avatar"><a href="http://twitter.com/SJUTorch" title="Torch Newspaper" target="_blank"><img alt='Torch Newspaper' src='https://pbs.twimg.com/profile_images/151281730/Torch_Logo_normal.jpg' /></a></div><ul><li><span class='entry-content'>Retweeted Torch Sports (@TorchSports):

Recapping the men's and women's soccer seasons <a href="http://twitter.com/search?q=%23SJUMSOC" class="twitter-hashtag" target="_blank">#SJUMSOC</a> <a href="http://twitter.com/search?q=%23SJUWSOC" class="twitter-hashtag" target="_blank">#SJUWSOC</a>... <a href="https://t.co/jYkyB2I13l" target="_blank">https://t.co/jYkyB2I13l</a></span> <span class='entry-meta'><span class='time-meta'><a href="http://twitter.com/SJUTorch/statuses/799625465141071872" target="_blank">about 4 days ago</a></span> <span class='from-meta'>from <a href="http://www.facebook.com/twitter" rel="nofollow">Facebook</a></span></span> <span class="intent-meta"><a href="http://twitter.com/intent/tweet?in_reply_to=799625465141071872" data-lang="en" class="in-reply-to" title="Reply" target="_blank">Reply</a><a href="http://twitter.com/intent/retweet?tweet_id=799625465141071872" data-lang="en" class="retweet" title="Retweet" target="_blank">Retweet</a><a href="http://twitter.com/intent/favorite?tweet_id=799625465141071872" data-lang="en" class="favorite" title="Favorite" target="_blank">Favorite</a></span></li><li><span class='entry-content'>Retweeted Torch Sports (@TorchSports):

Recapping the men's and women's soccer seasons <a href="http://twitter.com/search?q=%23SJUMSOC" class="twitter-hashtag" target="_blank">#SJUMSOC</a> <a href="http://twitter.com/search?q=%23SJUWSOC" class="twitter-hashtag" target="_blank">#SJUWSOC</a>... <a href="https://t.co/sK4dH8Vyrl" target="_blank">https://t.co/sK4dH8Vyrl</a></span> <span class='entry-meta'><span class='time-meta'><a href="http://twitter.com/SJUTorch/statuses/799625456068792320" target="_blank">about 4 days ago</a></span> <span class='from-meta'>from <a href="http://www.facebook.com/twitter" rel="nofollow">Facebook</a></span></span> <span class="intent-meta"><a href="http://twitter.com/intent/tweet?in_reply_to=799625456068792320" data-lang="en" class="in-reply-to" title="Reply" target="_blank">Reply</a><a href="http://twitter.com/intent/retweet?tweet_id=799625456068792320" data-lang="en" class="retweet" title="Retweet" target="_blank">Retweet</a><a href="http://twitter.com/intent/favorite?tweet_id=799625456068792320" data-lang="en" class="favorite" title="Favorite" target="_blank">Favorite</a></span></li><li><span class='entry-content'>RT <a href="http://twitter.com/TorchSports" class="twitter-user" target="_blank">@TorchSports</a>: Recapping the men's and women's soccer seasons <a href="http://twitter.com/search?q=%23SJUMSOC" class="twitter-hashtag" target="_blank">#SJUMSOC</a> <a href="http://twitter.com/search?q=%23SJUWSOC" class="twitter-hashtag" target="_blank">#SJUWSOC</a> <a href="https://t.co/TQjvNnEinr" target="_blank">https://t.co/TQjvNnEinr</a></span> <span class='entry-meta'><span class='time-meta'><a href="http://twitter.com/SJUTorch/statuses/799625428537262080" target="_blank">about 4 days ago</a></span> <span class='from-meta'>from <a href="http://twitter.com" rel="nofollow">Twitter Web Client</a></span></span> <span class="intent-meta"><a href="http://twitter.com/intent/tweet?in_reply_to=799625428537262080" data-lang="en" class="in-reply-to" title="Reply" target="_blank">Reply</a><a href="http://twitter.com/intent/retweet?tweet_id=799625428537262080" data-lang="en" class="retweet" title="Retweet" target="_blank">Retweet</a><a href="http://twitter.com/intent/favorite?tweet_id=799625428537262080" data-lang="en" class="favorite" title="Favorite" target="_blank">Favorite</a></span></li><li><span class='entry-content'>.@SJUWritingCtr recently celebrated its 20th anniversary: <a href="https://t.co/nCWl2bRRFY" target="_blank">https://t.co/nCWl2bRRFY</a></span> <span class='entry-meta'><span class='time-meta'><a href="http://twitter.com/SJUTorch/statuses/799625120683851776" target="_blank">about 4 days ago</a></span> <span class='from-meta'>from <a href="http://twitter.com" rel="nofollow">Twitter Web Client</a></span></span> <span class="intent-meta"><a href="http://twitter.com/intent/tweet?in_reply_to=799625120683851776" data-lang="en" class="in-reply-to" title="Reply" target="_blank">Reply</a><a href="http://twitter.com/intent/retweet?tweet_id=799625120683851776" data-lang="en" class="retweet" title="Retweet" target="_blank">Retweet</a><a href="http://twitter.com/intent/favorite?tweet_id=799625120683851776" data-lang="en" class="favorite" title="Favorite" target="_blank">Favorite</a></span></li><li><span class='entry-content'>Jane Elliott, an anti-racism activist and educator, visited St. John's last week. Read more about her lecture here: <a href="https://t.co/CFL1jzeCXU" target="_blank">https://t.co/CFL1jzeCXU</a></span> <span class='entry-meta'><span class='time-meta'><a href="http://twitter.com/SJUTorch/statuses/799310933717909504" target="_blank">about 5 days ago</a></span> <span class='from-meta'>from <a href="http://twitter.com" rel="nofollow">Twitter Web Client</a></span></span> <span class="intent-meta"><a href="http://twitter.com/intent/tweet?in_reply_to=799310933717909504" data-lang="en" class="in-reply-to" title="Reply" target="_blank">Reply</a><a href="http://twitter.com/intent/retweet?tweet_id=799310933717909504" data-lang="en" class="retweet" title="Retweet" target="_blank">Retweet</a><a href="http://twitter.com/intent/favorite?tweet_id=799310933717909504" data-lang="en" class="favorite" title="Favorite" target="_blank">Favorite</a></span></li></ul><div class="follow-button"><a href="http://twitter.com/sjutorch" class="twitter-follow-button" title="Follow @sjutorch" data-lang="en" target="_blank">@sjutorch</a></div></div></div><div class="widgetfooter3"></div></div><div style="clear:both"></div><div class="widgetwrap sno-animate"><div><div></div><div class="titlewrap"><h2><span class='twitterwidget twitterwidget-title'>Torch Sports Twitter</span></h2></div><div class="widgetbody"><div class="twitter-avatar"><a href="http://twitter.com/TorchSports" title="Torch Sports" target="_blank"><img alt='Torch Sports' src='https://pbs.twimg.com/profile_images/618153649374633984/qFsTEqUZ_normal.jpg' /></a></div><ul><li><span class='entry-content'>Women's basketball opens with win over William &amp; Mary <a href="http://twitter.com/search?q=%23SJUWB" class="twitter-hashtag" target="_blank">#SJUWB</a> <a href="https://t.co/hP6cqCZXEd" target="_blank">https://t.co/hP6cqCZXEd</a></span> <span class='entry-meta'><span class='time-meta'><a href="http://twitter.com/TorchSports/statuses/799089462131228672" target="_blank">about 5 days ago</a></span> <span class='from-meta'>from <a href="http://twitter.com" rel="nofollow">Twitter Web Client</a></span></span> <span class="intent-meta"><a href="http://twitter.com/intent/tweet?in_reply_to=799089462131228672" data-lang="en" class="in-reply-to" title="Reply" target="_blank">Reply</a><a href="http://twitter.com/intent/retweet?tweet_id=799089462131228672" data-lang="en" class="retweet" title="Retweet" target="_blank">Retweet</a><a href="http://twitter.com/intent/favorite?tweet_id=799089462131228672" data-lang="en" class="favorite" title="Favorite" target="_blank">Favorite</a></span></li><li><span class='entry-content'>St. John's dominates Bethune-Cookman for season-opening win <a href="http://twitter.com/search?q=%23SJUBB" class="twitter-hashtag" target="_blank">#SJUBB</a> <a href="https://t.co/GExTYxdJ6E" target="_blank">https://t.co/GExTYxdJ6E</a></span> <span class='entry-meta'><span class='time-meta'><a href="http://twitter.com/TorchSports/statuses/799089180991229952" target="_blank">about 5 days ago</a></span> <span class='from-meta'>from <a href="http://twitter.com" rel="nofollow">Twitter Web Client</a></span></span> <span class="intent-meta"><a href="http://twitter.com/intent/tweet?in_reply_to=799089180991229952" data-lang="en" class="in-reply-to" title="Reply" target="_blank">Reply</a><a href="http://twitter.com/intent/retweet?tweet_id=799089180991229952" data-lang="en" class="retweet" title="Retweet" target="_blank">Retweet</a><a href="http://twitter.com/intent/favorite?tweet_id=799089180991229952" data-lang="en" class="favorite" title="Favorite" target="_blank">Favorite</a></span></li><li><span class='entry-content'><a href="http://twitter.com/search?q=%23SJUBB" class="twitter-hashtag" target="_blank">#SJUBB</a>: New backcourt duo leads St. John's over Binghamton <a href="https://t.co/k2iSiO4JYs" target="_blank">https://t.co/k2iSiO4JYs</a></span> <span class='entry-meta'><span class='time-meta'><a href="http://twitter.com/TorchSports/statuses/799080487692148737" target="_blank">about 5 days ago</a></span> <span class='from-meta'>from <a href="http://twitter.com" rel="nofollow">Twitter Web Client</a></span></span> <span class="intent-meta"><a href="http://twitter.com/intent/tweet?in_reply_to=799080487692148737" data-lang="en" class="in-reply-to" title="Reply" target="_blank">Reply</a><a href="http://twitter.com/intent/retweet?tweet_id=799080487692148737" data-lang="en" class="retweet" title="Retweet" target="_blank">Retweet</a><a href="http://twitter.com/intent/favorite?tweet_id=799080487692148737" data-lang="en" class="favorite" title="Favorite" target="_blank">Favorite</a></span></li><li><span class='entry-content'><a href="http://twitter.com/search?q=%23SJUMTen" class="twitter-hashtag" target="_blank">#SJUMTen</a>: Roberto Livi making his mark at SJU <a href="https://t.co/wfVbpQS7aF" target="_blank">https://t.co/wfVbpQS7aF</a></span> <span class='entry-meta'><span class='time-meta'><a href="http://twitter.com/TorchSports/statuses/799080337116643331" target="_blank">about 5 days ago</a></span> <span class='from-meta'>from <a href="http://twitter.com" rel="nofollow">Twitter Web Client</a></span></span> <span class="intent-meta"><a href="http://twitter.com/intent/tweet?in_reply_to=799080337116643331" data-lang="en" class="in-reply-to" title="Reply" target="_blank">Reply</a><a href="http://twitter.com/intent/retweet?tweet_id=799080337116643331" data-lang="en" class="retweet" title="Retweet" target="_blank">Retweet</a><a href="http://twitter.com/intent/favorite?tweet_id=799080337116643331" data-lang="en" class="favorite" title="Favorite" target="_blank">Favorite</a></span></li><li><span class='entry-content'>Recapping the men's and women's soccer seasons <a href="http://twitter.com/search?q=%23SJUMSOC" class="twitter-hashtag" target="_blank">#SJUMSOC</a> <a href="http://twitter.com/search?q=%23SJUWSOC" class="twitter-hashtag" target="_blank">#SJUWSOC</a> <a href="https://t.co/TQjvNnEinr" target="_blank">https://t.co/TQjvNnEinr</a></span> <span class='entry-meta'><span class='time-meta'><a href="http://twitter.com/TorchSports/statuses/799080121156124672" target="_blank">about 5 days ago</a></span> <span class='from-meta'>from <a href="http://twitter.com" rel="nofollow">Twitter Web Client</a></span></span> <span class="intent-meta"><a href="http://twitter.com/intent/tweet?in_reply_to=799080121156124672" data-lang="en" class="in-reply-to" title="Reply" target="_blank">Reply</a><a href="http://twitter.com/intent/retweet?tweet_id=799080121156124672" data-lang="en" class="retweet" title="Retweet" target="_blank">Retweet</a><a href="http://twitter.com/intent/favorite?tweet_id=799080121156124672" data-lang="en" class="favorite" title="Favorite" target="_blank">Favorite</a></span></li></ul><div class="follow-button"><a href="http://twitter.com/torchsports" class="twitter-follow-button" title="Follow @torchsports" data-lang="en" target="_blank">@torchsports</a></div></div></div><div class="widgetfooter3"></div></div><div style="clear:both"></div><div class="widgetwrap sno-animate"><div></div><div class="titlewrap"><h2>Instagram </h2></div><div class="widgetbody">			<div class="textwidget"><div id="sb_instagram" class="sbi sbi_col_2" style="width:100%; padding-bottom: 10px; " data-id="1135080177" data-num="2" data-res="auto" data-cols="2" data-options='{&quot;sortby&quot;: &quot;none&quot;, &quot;headercolor&quot;: &quot;&quot;, &quot;imagepadding&quot;: &quot;5&quot;}'><div class="sb_instagram_header" style="padding: 10px; padding-bottom: 0;"></div><div id="sbi_images" style="padding: 5px;"><div class="sbi_loader fa-spin"></div></div><div id="sbi_load"><a class="sbi_load_btn" href="javascript:void(0);" style="">Load More...</a><div class="sbi_follow_btn"><a href="http://instagram.com/" onclick="__gaTracker('send', 'event', 'outbound-widget', 'http://instagram.com/', 'Follow on Instagram');" style="" target="_blank"><i class="fa fa-instagram"></i>Follow on Instagram</a></div></div></div></div>
		</div><div class="widgetfooter3"></div></div></div></div></div></div></div></div><div style="clear:both;"></div><div class="footerwrap"><div id="footer"><div class="footername"><div class="footerleft"><p><a href="http://www.torchonline.com">The Torch</a></p></div><div class="footerright social-classic"><style>.topnavbarleft { padding: 0px; width:auto; }</style><div class="social-spacer"></div></div></div><div class="footertagline"><p>The Independent Student Newspaper of St. John&#039;s University</p></div><div class="footersearch">	<form method="get" id="searchform" action="http://www.torchonline.com/">
			<label for="s" class="assistive-text">Search</label>
			<input type="text" class="field" name="s" id="s" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit" value="Search" />
		</form>
	</div><div class="clear"></div><div class="footercredit"><p>&copy; 2016  &bull; <a target='_blank' href='https://snosites.com/client-site-privacy-policy/'>Privacy Policy</a> &bull; <a href='https://snosites.com/why-sno/'>FLEX WordPress Theme</a> by <a href='http://snosites.com'>SNO</a> &bull; <a href="http://www.torchonline.com/wp-login.php">Log in</a></p></div><div class="clear"></div></div></div><script type="text/javascript">
// start of scroll to view

$(document).ready(function() {

var win = $(window);
var allMods = $(".sno-animate");
var allWPcaptions = $(".wp-caption");

// Already visible modules
allMods.each(function(i, el) {
  var el = $(el);
  if (el.visible(true)) {
    el.addClass("already-visible"); 
  } 
else {
  /*  Like this!  */
  el.css('visibility', 'hidden');
  }
});
allWPcaptions.each(function(i, el) {
  var el = $(el);
  if (el.visible(true)) {
    el.addClass("already-visible"); 
  } 
});


$(window).scroll(function(event) {
  
  $(".sno-animate").each(function(i, el) {
    var el = $(el);
    if (el.visible(true)) {
      	el.addClass("come-in");     
	    el.css('visibility', 'visible'); // Visible
    } 
  });
  $(".wp-caption").each(function(i, el) {
    var el = $(el);
    if (el.visible(true)) {
      	el.addClass("come-in");     
	    el.css('visibility', 'visible'); // Visible
    } 
  });
  
});


});
//end of scroll to view
</script>
<script type="text/javascript">

( function( $ ) {
 /*** 
  * Run this code when the #toggle-menu link has been tapped
  * or clicked
  */
 $( '#mobile_menu_icon' ).on( 'touchstart click', function(e) {
  e.preventDefault();

  var $body = $( 'body' ),
      $page = $( '#wrap' ),
      $menu = $( '#menu' ),
 
      /* Cross browser support for CSS "transition end" event */
      transitionEnd = 'transitionend webkitTransitionEnd otransitionend MSTransitionEnd';

  /* When the toggle menu link is clicked, animation starts */
  $body.addClass( 'animating' );

  /***
   * Determine the direction of the animation and
   * add the correct direction class depending
   * on whether the menu was already visible.
   */
  if ( $body.hasClass( 'menu-visible' ) ) {
   $body.addClass( 'right' );
  } else {
   $body.addClass( 'left' );
  }
  
  /***
   * When the animation (technically a CSS transition)
   * has finished, remove all animating classes and
   * either add or remove the "menu-visible" class 
   * depending whether it was visible or not previously.
   */
  $page.on( transitionEnd, function() {
   $body
    .removeClass( 'animating left right' )
    .toggleClass( 'menu-visible' );

   $page.off( transitionEnd );
  } );
 } );
} )( jQuery );

</script>	<script>
		var getElementsByClassName=function(a,b,c){if(document.getElementsByClassName){getElementsByClassName=function(a,b,c){c=c||document;var d=c.getElementsByClassName(a),e=b?new RegExp("\\b"+b+"\\b","i"):null,f=[],g;for(var h=0,i=d.length;h<i;h+=1){g=d[h];if(!e||e.test(g.nodeName)){f.push(g)}}return f}}else if(document.evaluate){getElementsByClassName=function(a,b,c){b=b||"*";c=c||document;var d=a.split(" "),e="",f="http://www.w3.org/1999/xhtml",g=document.documentElement.namespaceURI===f?f:null,h=[],i,j;for(var k=0,l=d.length;k<l;k+=1){e+="[contains(concat(' ', @class, ' '), ' "+d[k]+" ')]"}try{i=document.evaluate(".//"+b+e,c,g,0,null)}catch(m){i=document.evaluate(".//"+b+e,c,null,0,null)}while(j=i.iterateNext()){h.push(j)}return h}}else{getElementsByClassName=function(a,b,c){b=b||"*";c=c||document;var d=a.split(" "),e=[],f=b==="*"&&c.all?c.all:c.getElementsByTagName(b),g,h=[],i;for(var j=0,k=d.length;j<k;j+=1){e.push(new RegExp("(^|\\s)"+d[j]+"(\\s|$)"))}for(var l=0,m=f.length;l<m;l+=1){g=f[l];i=false;for(var n=0,o=e.length;n<o;n+=1){i=e[n].test(g.className);if(!i){break}}if(i){h.push(g)}}return h}}return getElementsByClassName(a,b,c)},
			dropdowns = document.getElementsByTagName( 'select' );
		for ( i=0; i<dropdowns.length; i++ )
			if ( dropdowns[i].className.match( 'dropdown-menu' ) ) dropdowns[i].onchange = function(){ if ( this.value != '' ) window.location.href = this.value; }
	</script>
	
		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-22842225-9', 'auto');
			ga('require', 'displayfeatures');
			ga('send', 'pageview');
		</script> 	
		
		
		<script type="text/javascript">
			var _gaq = _gaq || [];
			_gaq.push(['_setAccount', 'UA-31058813-1']);
			_gaq.push(['_trackPageview']);
			(function() {
				var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
				ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
				var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
			})();
		</script>		

	      <script type="text/javascript">

          var pfHeaderImgUrl = '';
          var pfHeaderTagline = '';
          var pfdisableClickToDel = '0';
          var pfHideImages = '0';
          var pfImageDisplayStyle = 'right';
          var pfDisableEmail = '0';
          var pfDisablePDF = '0';
          var pfDisablePrint = '0';
          var pfCustomCSS = '';
      (function() {
            var e = document.createElement('script'); e.type="text/javascript";
        if('https:' == document.location.protocol) {
        js='https://pf-cdn.printfriendly.com/ssl/main.js';
        }
        else{
        js='http://cdn.printfriendly.com/printfriendly.js';
        }
            e.src = js;
            document.getElementsByTagName('head')[0].appendChild(e);
        })();
      </script>
<script type='text/javascript' src='http://www.torchonline.com/wp-content/plugins/prettyphoto-media/js/jquery.prettyPhoto.min.js?ver=3.1.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/www.torchonline.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.torchonline.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript' src='http://www.torchonline.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"loaderUrl":"http:\/\/www.torchonline.com\/wp-content\/plugins\/contact-form-7\/images\/ajax-loader.gif","recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"sending":"Sending ..."};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.torchonline.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sb_instagram_js_options = {"sb_instagram_at":"1135080177.3a81a9f.2c9a11f03945426787f550250e16de21"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.torchonline.com/wp-content/plugins/instagram-feed/js/sb-instagram.min.js?ver=1.4.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"http:\/\/www.torchonline.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.torchonline.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.1'></script>
<script type='text/javascript' src='http://www.torchonline.com/wp-includes/js/wp-embed.min.js?ver=4.6.1'></script>
<script type='text/javascript' src='http://platform.twitter.com/widgets.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://www.torchonline.com/wp-content/plugins/my-calendar/js/mc-grid.js?ver=4.6.1'></script>
<script type='text/javascript' src='http://www.torchonline.com/wp-content/plugins/my-calendar/js/mc-list.js?ver=4.6.1'></script>
<script type='text/javascript' src='http://www.torchonline.com/wp-content/plugins/my-calendar/js/mc-mini.js?ver=4.6.1'></script>
<script>
jQuery(function($) {
$('a[rel^="prettyPhoto"]').prettyPhoto({ default_width: 750, default_height: 500 });
});
</script>
</div><div id="sno_hoversearch"><div class="sno-search-close foundation-icons fi-x" style="float:right;"></div><div class="hover-search-area"><form method="get" id="searchform-alt" action="http://www.torchonline.com/">
											<label for="s" class="assistive-text">Search</label>
											<input type="text" class="field" name="s" id="s-alt" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
											<input type="submit" class="submit" name="submit" id="searchsubmit" value="Search" />
											<div type="submit" id="sno-hover-search-button" class="sno-submit-search sno-search fa fa-search"></div>
										</form></div></div><div id="sno_hoverbar"><div class="hoverheader"><div id="hover-menu"><div class="sno-menu menu-icon dashicons dashicons-menu"></div><div class="sno-menu close-icon foundation-icons fi-x" style="display:none;"></div></div><div id="search-top"><div class="sno-search-button fa fa-search"></div></div><div class="socialmedia"><div class="sharing sharing-top"><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.torchonline.com%2Fsports%2F2016%2F11%2F22%2Fcourtside-allow-me-to-reintroduce-myself%2F" title="Share on Facebook" target="_blank"><div class="sharing-icon sharing-mobile sno-facebook dashicons dashicons-facebook-alt sno-dark sharing-mobile-hide"></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=Courtside%3A+Allow+me+to+reintroduce+myself&amp;url=http%3A%2F%2Fwww.torchonline.com%2F%3Fp%3D2232799" title="Tweet This Story" target="_blank"><div class="sharing-icon sharing-mobile sno-twitter dashicons dashicons-twitter sno-dark sharing-mobile-hide"></div></a><a data-remodal-target="modal"><div class="sharing-icon sno-email dashicons dashicons-email-alt sno-dark sharing-mobile-hide"></div></a></div>			<script type="text/javascript">
				$(document).ready(function() {
					$(function(){
						$('.modal-share').click(function() {
							var inst = $('[data-remodal-id=modal-share]').remodal();
							inst.open();

							var sharestoryid = '2232799';

							$.ajax({
	                			url:"/wp-admin/admin-ajax.php",
								type:'POST',
								data:'action=sharestory&sharestoryid=' + sharestoryid,
								success:function(results)
	            					{ $("#suggestedstories").replaceWith(results); }
	           				});

						});
										
					});
				});
			</script>

			<div class="remodal" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false">
  				<button data-remodal-action="close" class="remodal-close"></button>
  				<div id="suggestedstories">
  				<h1>Hang on for a minute...we're trying to find some more stories you might like.</h1>
  				<form method="post" action="">

  				<br />
  				<button data-remodal-action="cancel" class="remodal-cancel">Close</button>

  				</form>
  				</div>
			</div>

					<div class="remodal" data-remodal-id="modal" data-remodal-options="hashTracking: false, closeOnConfirm: false">
  				<button data-remodal-action="close" class="remodal-close"></button>
  				<div id="emailstoryform">
  				<h1>Email This Story</h1>
  				<form method="post" action="">
  				<input type="text" id="email_to_Bar" name="email_to_Bar" class="sno_email_fields" placeholder="Send email to this address"><br />
  				<input type="text" id="email_from_Bar" name="email_from_Bar" class="sno_email_fields" placeholder="Enter Your Name"><br />
  				<textarea rows="4" id="email_comment_Bar" name="email_comment_Bar" class="sno_email_fields" placeholder="Add a comment here (optional)."></textarea><br />
  				<input type="text" id="human_Bar" name="human_Bar" class="sno_email_fields" placeholder="What's 9 + 7?"><br />

  				<br />
  				<button id="submit_email_Bar" data-remodal-action="confirm" class="remodal-confirm">Send Email</button>
  				<button data-remodal-action="cancel" class="remodal-cancel">Cancel</button>
  				<input type="hidden" id="sno_email_submission_form" name="sno_email_submission_form" value="d8a60ab200" /><input type="hidden" name="_wp_http_referer" value="/sports/2016/11/22/courtside-allow-me-to-reintroduce-myself/" />
  				</form>
  				</div>
			</div>
										<script>
								$(document).ready(function() {

								$(function(){
           							$('#submit_email_Bar').click(function(){
											var storyid = '2232799';
											var datastring = '';
											if ($("#email_to_Bar").length > 0){
												var email_to = $('input[name=email_to_Bar]');
												datastring += '&email_to=' + encodeURIComponent(email_to.val());
       										}

											if ($("#email_from_Bar").length > 0){
												var email_from = $('input[name=email_from_Bar]');
												datastring += '&email_from=' + encodeURIComponent(email_from.val());
       										}

											if ($("#email_comment_Bar").length > 0){
												var email_comment = $('textarea[name=email_comment_Bar]');
												datastring += '&email_comment=' + encodeURIComponent(email_comment.val());
       										}

											if ($("#human_Bar").length > 0){
												var human = $('input[name=human_Bar]');
												datastring += '&human=' + encodeURIComponent(human.val());
       										}
       										
	   										datastring += '&humanity=' + 16;

       										var verification = $('input[name=sno_email_submission_form]');
	   										datastring += '&verification=' + verification.val();
       										
										//	var parentid = '';
               							$.ajax({
                				            url:"/wp-admin/admin-ajax.php",
                				            type:'POST',
                				            data:'action=emailstory&storyid=' + storyid + datastring,
 	            				            success:function(results)
	            				            { $("#emailstoryform").replaceWith(results); }
	           				    	  	});
	         						});
								});
								});

							</script>

			</div><div id="back-top"><a id="snotop" href="#top" title="Return to Top"><div class="sno-arrow-up fa fa-arrow-up"></div></a></div><div class="lf_headerleft"><a href="/"><img src="http://www.torchonline.com/wp-content/uploads/2013/08/Screen-shot-2013-07-26-at-10.37.04-AM1.png" alt="The Independent Student Newspaper of St. John&#039;s University" /></a></div><div class="hover_title"><div class="hover_titletext">Courtside: Allow me to reintroduce myself</div><span id="progress-bar"><span id="progress-bar-color"></span></span></div></div><div class="clear"></div></div><div id="hoverbar_menu"><ul id="slidemenu" class="mobile-menu"><li class="mobile-search"><form method="get" id="searchform-alt" action="http://www.torchonline.com/">
									<label for="s" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" id="searchsubmit" value="Search" />
								</form></li><div class="clear"></div><div class="mobile-menu"><ul id="menu-top-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-206"><a href="http://www.torchonline.com">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-208"><a href="http://www.torchonline.com/about/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-210"><a href="http://www.torchonline.com/about/staff/">Staff</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2222954"><a href="http://www.torchonline.com/advertising/">Advertising</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2228097"><a href="http://www.torchonline.com/pdfissues/">Full Issues</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2228108"><a href="http://www.torchonline.com/subscriptions/">Subscriptions</a></li>
</ul></div></ul></div><script type="text/javascript">
		$(document).ready(function(){
			

			function sharingIconsResize() {
				if ($(window).width() < 850) {
					var socialwidth;
					var count = $("#mobile-socialmedia .sharing-mobile-show").length;
					if (count != 0) {
						socialwidth = 100 / count;
						$('#mobile-socialmedia .sharing-icon').width(socialwidth + '%');
					}
				} else {
					$('#sno_hoverbar .sharing-icon').width('50px');
				}
			}
						
			$('.sno-search-button').click(function() {
				$('#sno_hoversearch').fadeToggle();
				$('#sno_hoversearch').css({ top: '0' });
			});
			$('.sno-search-close').click(function() {
				$('#sno_hoversearch').fadeToggle();
				$('#sno_hoversearch').css({ top: '-50px' });
			});

			var NavScrollTop		= $(window).scrollTop();
    		
    		if( $('.navbarwrap').length ) {
    			var	TopNavOffset 		= $('.navbarwrap').offset().top;
				var TopNavDistance		= (TopNavOffset - NavScrollTop);
   	 		}
   	 		if( $('.subnavbarwrap').length ) {
	   	 		var	BottomNavOffset 	= $('.subnavbarwrap').offset().top;
	   	 		var	BottomNavDistance	= (BottomNavOffset - NavScrollTop);
   	 		}
   	 		
   	 		$('.mobile-menu').height( $(window).height() - 95);
   	 		
   	 		var HoverOffset = 0, HoverOffset2 = 0;
			   	 		var HoverHeight = $('#sno_hoverbar').outerHeight();
   	 		var HoverHeight2 = $('#sno_hoverbar').outerHeight();
   	 		
			
			var CurrentScroll = 0;
			var WindowHeight = $(document).height() - $('.footerwrap').height();
			
						
			
			$('.sno-menu').click(function() {
			
				$('#hoverbar_menu').fadeToggle();
				$('.menu-icon').toggle();
				$('.close-icon').toggle();
				$('#hoverbar_menu').css({ height: $(window).height() - 50 });
			
			});
			
			$(window).scroll(function(event) {
				var NextScroll = $(this).scrollTop();

				var ScrollPercent = (NextScroll / (WindowHeight - $(window).height())) * 100;
				

				$('#progress-bar-color').css({ width: ScrollPercent + '%'});
				$('#hoverbar_menu').css({ top: $('#sno_hoverbar').height() });
				
				if ( ScrollPercent > 100 ) {
										$('.sno-arrow-up').css({ background: '#cc0000', color: '#eee'});
					$('.sno-menu').css({ background: '#cc0000', color: '#eee'});
					$('.socialmedia .sharing-icon').css({ opacity: 1 })
					
					
				} else {
										$('.sno-arrow-up').css({ background: '#eee', color: '#ccc'});
					$('.sno-menu').css({ background: '#eee', color: '#ccc'});
				}
				
				if (NextScroll > CurrentScroll && $(document).scrollTop() > 300) {
					if ($('#sno_hoverbar').is(":hidden")) {
						$('#sno_hoverbar').show();
						$('#sno_hoverbar').stop().animate({ top: '0' }, { duration: 300, queue: false });
						
												
													var lpb = $('.lf_headerleft').width();
							lpb += $('#sno_hoverbar .sno-menu').width(); 							var rpb = 50 + $('.socialmedia').width();
															rpb += $('#sno_hoverbar .sno-search-button').width();
														$('#progress-bar').css({ left: lpb + 'px', right: rpb + 'px'})
						        			}


        			
				} else if (NextScroll < CurrentScroll && $(document).scrollTop() < 300 && $('#sno_hoverbar').is(":visible")) {
				
						$('#hoverbar_menu').hide();
						$('.close-icon').hide();
						$('.menu-icon').show();
						$('#hoverbar_menu').hide();
						$('#sno_hoverbar').stop().animate({
							top: '-50px'
							},300, function(){
								$('#sno_hoverbar').hide();
							});
						if ( $('.navbarwrap').length ) { $('.navbarwrap').stop().animate({ top: HoverOffset + 'px'},300); }
						if ( $('.subnavbarwrap').length ) { $('.subnavbarwrap').stop().animate({ top: HoverOffset2 + 'px'},300); }

				}
			CurrentScroll = NextScroll;
			});


		});

		$("#snotop").hide();
	
		$(function () {
			$(window).scroll(function () {
				if ($(this).scrollTop() > 500) {
					$('#snotop').fadeIn();
				} else {
					$('#snotop').fadeOut();
				}
			});

			$('#back-top a').click(function () {
				$('body,html').animate({
					scrollTop: 0
				}, 800);
				return false;
			});

		});
	</script></body></html>