<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"> 
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="language" content="en, sv" />

<meta name="generator" content="WordPress 4.9.5" />
<meta name="viewport" content="width=device-width,maximum-scale=1.0" />
			<script type="text/javascript">
			var addToHomeConfig = {
			expire: 10000,
			touchIcon: true
		};
		</script>
		<link rel="stylesheet" href="https://www.torchonline.com/wp-content/themes/snoflex/tools/addtohome/add2home.css">
		<script type="application/javascript" src="https://www.torchonline.com/wp-content/themes/snoflex/tools/addtohome/add2home.js"></script>
		<meta name="apple-mobile-web-app-capable" content="yes">
	<link rel="apple-touch-icon" href="https://www.torchonline.com/wp-content/uploads/2017/08/Square-Torch-Logo.png" /><link rel="Shortcut Icon" href="https://www.torchonline.com/wp-content/uploads/2017/08/Torch-Favicon-1.png" type="image/x-icon" />
<link rel="alternate" type="application/rss+xml" title="The Torch RSS 2.0" href="https://www.torchonline.com/feed/" />
<link rel="alternate" type="text/xml" title="The Torch RSS .92" href="https://www.torchonline.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="The Torch Atom 0.3" href="https://www.torchonline.com/feed/atom/" />
<link rel="pingback" href="https://www.torchonline.com/xmlrpc.php" />


<title>PLUG Ticket Sweeps SGI Elections &#8211; The Torch</title>
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Torch &raquo; PLUG Ticket Sweeps SGI Elections Comments Feed" href="https://www.torchonline.com/news/2018/04/11/plug-ticket-sweeps-sgi-elections/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.2.8 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
		var disableStr = 'ga-disable-UA-59055616-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-59055616-1', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('require', 'displayfeatures');
	__gaTracker('send','pageview');
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.torchonline.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
		<style type="text/css">
				</style>
	<link rel='stylesheet' id='prettyphoto-css'  href='https://www.torchonline.com/wp-content/plugins/prettyphoto-media/css/prettyPhoto.css?ver=3.1.4' type='text/css' media='screen' />
<link rel='stylesheet' id='farbtastic-css'  href='https://www.torchonline.com/wp-admin/css/farbtastic.min.css?ver=1.3u1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.torchonline.com/wp-includes/css/dashicons.min.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://www.torchonline.com/wp-includes/js/thickbox/thickbox.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='elusive-css'  href='https://www.torchonline.com/wp-content/plugins/menu-icons/vendor/kucrut/icon-picker/css/types/elusive.min.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.torchonline.com/wp-content/plugins/menu-icons/vendor/kucrut/icon-picker/css/types/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='foundation-icons-css'  href='https://www.torchonline.com/wp-content/plugins/menu-icons/vendor/kucrut/icon-picker/css/types/foundation-icons.min.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='menu-icons-extra-css'  href='https://www.torchonline.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.11.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://www.torchonline.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://www.torchonline.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.8' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background: #d8e1eb;
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Lato%3A400%2C700%7COxygen%3A400%2C700%7CRoboto%3A400%2C700%7CArimo%3A400%2C700&#038;ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='flex-parallax-css'  href='https://www.torchonline.com/wp-content/themes/snoflex/parallax/css/main.css?ver=20180212' type='text/css' media='all' />
<link rel='stylesheet' id='flex-flexslider-css'  href='https://www.torchonline.com/wp-content/themes/snoflex/tools/flexslider/flexslider.css?ver=20180207' type='text/css' media='all' />
<link rel='stylesheet' id='flex-superfish-css'  href='https://www.torchonline.com/wp-content/themes/snoflex/tools/superfish/css/superfish.css?ver=20180207' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-css'  href='https://www.torchonline.com/wp-content/themes/snoflex/javascript/remodal.css?ver=20180207' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-default-css'  href='https://www.torchonline.com/wp-content/themes/snoflex/javascript/remodal-default-theme.css?ver=20180207' type='text/css' media='all' />
<link rel='stylesheet' id='flex-stylesheet-css'  href='https://www.torchonline.com/wp-content/themes/snoflex/style.css?ver=20180405' type='text/css' media='all' />
<link rel='stylesheet' id='wp-paginate-css'  href='https://www.torchonline.com/wp-content/plugins/wp-paginate/css/wp-paginate.css?ver=2.0.4' type='text/css' media='screen' />
            <script>
                if (document.location.protocol != "https:") {
                    document.location = document.URL.replace(/^http:/i, "https:");
                }
            </script>
            <script type='text/javascript' src='https://www.torchonline.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"","home_url":"https:\/\/www.torchonline.com","track_download_as":"event","internal_label":"int","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/plugins/sno-google-analytics-for-wordpress/assets/js/frontend.min.js?ver=6.2.8'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/javascript/jquery.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/tools/flexslider/jquery.flexslider.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/javascript/jquery-visible.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/tools/superfish/js/hoverIntent.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/tools/superfish/js/superfish.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/tools/superfish/js/supersubs.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/javascript/jquery-scrolltofixed-min.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/javascript/remodal.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/javascript/jquery.cycle.all.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/javascript/jcarousellite_1.0.1c4.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/javascript/menus-init.js?ver=4.9.5'></script>
<link rel='https://api.w.org/' href='https://www.torchonline.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.torchonline.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.torchonline.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Yakwe Leaves St. John&#8217;s. Are Ponds and Owens Next?' href='https://www.torchonline.com/sports/2018/04/05/yakwe-leaves-st-johns-are-ponds-and-owens-next/' />
<meta name="generator" content="WordPress 4.9.5" />
<link rel="canonical" href="https://www.torchonline.com/news/2018/04/11/plug-ticket-sweeps-sgi-elections/" />
<link rel='shortlink' href='https://www.torchonline.com/?p=2236293' />
<link rel="alternate" type="application/json+oembed" href="https://www.torchonline.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.torchonline.com%2Fnews%2F2018%2F04%2F11%2Fplug-ticket-sweeps-sgi-elections%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.torchonline.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.torchonline.com%2Fnews%2F2018%2F04%2F11%2Fplug-ticket-sweeps-sgi-elections%2F&#038;format=xml" />
    <style type="text/css" media="screen">
      div.printfriendly a, div.printfriendly a:link, div.printfriendly a:hover, div.printfriendly a:visited {
        text-decoration: none;
        border: none;
      }
    </style>
           <style type="text/css" media="screen">
          div.printfriendly {
            margin: 12px 12px 12px 12px;
            position: relative;
            z-index: 1000;
          }
          div.printfriendly a, div.printfriendly a:link, div.printfriendly a:visited {
            font-size: 14px;
            color: #6D9F00;
            vertical-align: bottom;
          }
          .printfriendly a {
            box-shadow:none;
          }
          .printfriendly a:hover {
            cursor: pointer;
          }
          .printfriendly a img  {
            border: none;
            padding:0;
            margin-right: 6px;
            box-shadow: none;
            -webkit-box-shadow: none;
            -moz-box-shadow: none;
          }
          .printfriendly a span{
            vertical-align: bottom;
          }
          .pf-alignleft {
            float: left;
          }
          .pf-alignright {
            float: right;
          }
          div.pf-aligncenter {
            display: block;
            margin-left: auto;
            margin-right: auto;
            text-align: center;
          }
        </style>
        <style type="text/css" media="print">
          .printfriendly {
            display: none;
          }
        </style>

	<meta property="og:title" content="PLUG Ticket Sweeps SGI Elections" />
	<meta property="og:type" content="article" />
	<meta name="author" content="Nick Bello" />
	<meta property="og:url" content="https://www.torchonline.com/news/2018/04/11/plug-ticket-sweeps-sgi-elections/" />
	<meta property="og:image" content="https://www.torchonline.com/wp-content/uploads/2018/03/IMG_1888.png" />
	<meta property="og:image:width" content="838" />
	<meta property="og:image:height" content="768" />
	<meta property="og:site_name" content="The Torch" />
	<meta property="og:description" content="Student Government Inc.’s executive board elections came to a close Friday afternoon with the PLUG ticket coming out on top with a sweep. PLUG, which stands for personality, legacy, unity and growth, was led by junior Atem Tazi who beat out Roderick Jackson 1314 votes to 929. With the win, Tazi becomes the second black..." />
	<meta name="description" content="Student Government Inc.’s executive board elections came to a close Friday afternoon with the PLUG ticket coming out on top with a sweep. PLUG, which stands for personality, legacy, unity and growth, was led by junior Atem Tazi who beat out Roderick Jackson 1314 votes to 929. With the win, Tazi becomes the second black..." />
	<meta property="article:section" content="Home Scroll" />
	<meta property="article:tag" content="PLUG,SGI,SGI Elections,Student Government Inc." />
<!-- End of Facebook Meta Tags -->
<!-- wp thread comment 1.4.9.4.002 -->
<style type="text/css" media="screen">

.editComment, .editableComment, .textComment{
	display: inline;
}
.comment-childs{
	border: 1px solid #999;
	margin: 5px 2px 2px 4px;
	padding: 4px 2px 2px 4px;
	background-color: white;
}
.chalt{
	background-color: #E2E2E2;
}
#newcomment{
	border:1px dashed #777;width:90%;
}
#newcommentsubmit{
	color:red;
}
.adminreplycomment{
	border:1px dashed #777;
	width:99%;
	margin:4px;
	padding:4px;
}
.mvccls{
	color: #999;
}
			
</style>
<script src="/wp-content/themes/snoflex/parallax/js/skrollr.js"></script>

<script>
	$(document).ready(function() {
		var wpadminbar = $('#wpadminbar').outerHeight();
		if (wpadminbar == null) { var wpadminbar = 0; }
		if ($('#wpadminbar').is(":hidden")) { wpadminbar = 0; }

	
				$('.subnavbarwrap').scrollToFixed({
			marginTop:  wpadminbar,
		});		
		
			var topmenuTop = $('.navbarwrap').offset().top;
		topmenuTop -= wpadminbar;
		$(window).scroll(function () {
			if ($(this).scrollTop() > topmenuTop) {
				$('#navbar .mini-logo').hide();
				$('#show-mini-logo-top').fadeIn();
				if ( $.isFunction($.fn.resizeMenuTop)) resizeMenuTop();
				
			} else {
				$('#show-mini-logo-top').hide();
				$('#navbar .mini-logo').fadeIn();
			}
		});
		
		
	
	});
</script>


<style type="text/css" media="screen">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</style>
</head>

<body><div id="sno_mobile_menu"><ul id="slidemenu" class="mobile-menu"><div class="sno-side-menu side-close-icon foundation-icons fi-x"><span class="icon-hidden-text">Close Menu</span></div><li class="mobile-search-side"><form method="get" id="searchform-alt-left" action="https://www.torchonline.com/">
									<label for="s-alt-left" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" id="searchsubmit-left" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="mobile-menu"><ul id="menu-top-menu" class="menu"><li id="menu-item-2234331" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-2234331"><a href="https://www.torchonline.com">Home</a></li>
<li id="menu-item-208" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-208"><a href="https://www.torchonline.com/about/">About</a>
<ul class="sub-menu">
	<li id="menu-item-2234920" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234920"><a href="https://www.torchonline.com/about/">About</a></li>
	<li id="menu-item-210" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-210"><a href="https://www.torchonline.com/about/staff/">Staff</a></li>
	<li id="menu-item-2234919" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234919"><a href="https://www.torchonline.com/join/">Join</a></li>
</ul>
</li>
<li id="menu-item-2222954" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2222954"><a href="https://www.torchonline.com/advertising/">Advertising</a></li>
<li id="menu-item-2234320" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234320"><a href="https://www.torchonline.com/job-board/">Job Board</a></li>
<li id="menu-item-2234335" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234335"><a href="https://www.torchonline.com/classifieds/">Classifieds</a></li>
<li id="menu-item-2228097" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2228097"><a href="https://www.torchonline.com/pdfissues/">Full Issues</a></li>
<li id="menu-item-2228108" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2228108"><a href="https://www.torchonline.com/subscriptions/">Subscribe</a></li>
<li id="menu-item-2234251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2234251"><a href="https://www.torchonline.com/story-submission/">Story Submission</a>
<ul class="sub-menu">
	<li id="menu-item-2234653" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234653"><a href="https://www.torchonline.com/story-submission/">Story Submission</a></li>
	<li id="menu-item-2234652" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234652"><a href="https://www.torchonline.com/pitch-to-us/">Pitch to Us!</a></li>
</ul>
</li>
</ul></div></ul></div><div id="wrap" class="bodywrap"><div id="mobile-menu"><div class="sitetitle"><div class="headerlink headersmall" style="display:none"><img src="https://www.torchonline.com/wp-content/uploads/2017/10/Torch-logo-copy.png" class="headerimage" alt="The Independent Student Newspaper of St. John&#039;s University" /></div><div class="headerlink headermedium" style="display:none"><img src="https://www.torchonline.com/wp-content/uploads/2017/10/Torch-logo-copy.png" class="headerimage" alt="The Independent Student Newspaper of St. John&#039;s University" /></div><div class="headerlink headerlarge"><img src="https://www.torchonline.com/wp-content/uploads/2017/10/Torch-logo-copy.png" class="headerlink headerimage" alt="The Independent Student Newspaper of St. John&#039;s University" /></div><h1 style="display:none">The Torch</h1><script type="text/javascript">
						$(document).ready(function(){
							$(".headerlink").click(function(){
								window.location="https://www.torchonline.com";

							});
						});
					</script><div id="hover-menu-side"><div class="sno-menu-side menu-icon dashicons dashicons-menu"><span class="icon-hidden-text">Menu</span></div></div></div><div class="clear"></div></div><div class="navbarwrap"><div class="navbarcontainer"><div id="navbar"><div id="navbarbackground"><div id="menu-a-menu"><nav role="navigation" aria-label="Secondary Menu"><div class="menu-top-menu-container"><ul id="menu-top-menu-1" class="sf-menu sno-top-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-2234331"><a href="https://www.torchonline.com">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-208"><a href="https://www.torchonline.com/about/">About</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234920"><a href="https://www.torchonline.com/about/">About</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-210"><a href="https://www.torchonline.com/about/staff/">Staff</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234919"><a href="https://www.torchonline.com/join/">Join</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2222954"><a href="https://www.torchonline.com/advertising/">Advertising</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234320"><a href="https://www.torchonline.com/job-board/">Job Board</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234335"><a href="https://www.torchonline.com/classifieds/">Classifieds</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2228097"><a href="https://www.torchonline.com/pdfissues/">Full Issues</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2228108"><a href="https://www.torchonline.com/subscriptions/">Subscribe</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2234251"><a href="https://www.torchonline.com/story-submission/">Story Submission</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234653"><a href="https://www.torchonline.com/story-submission/">Story Submission</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234652"><a href="https://www.torchonline.com/pitch-to-us/">Pitch to Us!</a></li>
</ul>
</li>
</ul></div></nav></div><ul id='menu-more-top' class='sf-menu sf-js-enabled sf-shadow' style='display:none'><li id="menu-more-item-top" style="float:left;"><a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"> »</span></a>
								<ul id="add-more-top" class="sub-menu"></ul>
								</li>
							</ul></div></div></div></div><div class="clear"></div><script type="text/javascript">
					$(document).ready(function() {
						
						if ($( window).width() < 980) { return; }

						resizeMenuTop();
					})
					$(window).load(function() {
						
						if ($( window).width() < 980) { return; }

						resizeMenuTop();
					})
					
					function resizeMenuTop() {
						
						if ($( window).width() < 980) { return; }

						var moreWidthTop = 0; var menubufferTop = 0; var minilogoTop = 0;

						if ($('#menu-more-top').is(':visible')) { moreWidthTop = $('#menu-more-top').width(); }			
																															var MenuTopWidth = 970;
												
						if ($('#menu-a-menu').width() + menubufferTop + minilogoTop + moreWidthTop > MenuTopWidth) 
						{ 
							$('.sno-top-menu > li:last-child').addClass('sub-menu'); 
							$('.sno-top-menu > li:last-child').appendTo('#add-more-top'); 
							if ($('#menu-more-top').is(':hidden')) { $('#menu-more-top').css({display: "block"}); }			
							if ($('#menu-a-menu').width() + menubufferTop + minilogoTop + moreWidthTop > MenuTopWidth) resizeMenuTop(); 
						} 
						 
					}
					$( window ).scroll(function() {
						
						if ($( window).width() < 980) { return; }

						resizeMenuTop();
					});
            		$( window ).resize(function() { 
	            		
             	   		if ($( window).width() > 980) { resizeMenuTop(); };
            		});   
 				</script><div class="headerwrap"><div id="header" style="position:relative;"><div class="headerlarge"><a href="https://www.torchonline.com"><img src="https://www.torchonline.com/wp-content/uploads/2017/10/Torch-logo-copy.png" class="headerimage" alt="The Independent Student Newspaper of St. John&#039;s University" /></a></div><h1 style="display:none">The Torch</h1><div class="header-icons"><style>.topnavbarleft { padding: 0px; width:auto; }</style><a aria-hidden="true" target="_blank" href="https://www.youtube.com/channel/UC27raD8kuNmoCAfG6Q3I3uw">
        		<div class="alt-header-social-fa social-border sno-youtube fa fa-youtube"><span class="icon-hidden-text">YouTube</span></div>
        	</a><a aria-hidden="true" target="_blank" href="https://www.instagram.com/sju_torch/">
        		<div class="alt-header-social-fa social-border sno-instagram fa fa-instagram"><span class="icon-hidden-text">Instagram</span></div>
        	</a><a aria-hidden="true" target="_blank" href="https://twitter.com/sjutorch?lang=en">
        		<div class="alt-header-social social-border sno-twitter dashicons dashicons-twitter"><span class="icon-hidden-text">Twitter</span></div>
        	</a><a aria-hidden="true" target="_blank" href="https://www.facebook.com/STJTorch/?fref=ts">
        		<div class="alt-header-social social-border sno-facebook dashicons dashicons-facebook-alt"><span class="icon-hidden-text">Facebook</span></div>
        	</a><div class="social-spacer"></div></div><div class="header-search">	<form method="get" id="searchform6453" action="https://www.torchonline.com/">
			<label for="s6453" class="assistive-text">Search</label>
			<div class="search-button-container" id="searchthis6453">
			<button type="submit" disabled="disabled" id="sno-search-navbar-6453" class="sno-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
			<input type="text" class="field s" name="s" id="s6453" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit6453" style="display:none;" value="Search" />
		</form>
	</div></div></div><div class="bottom-menu"><div class="subnavbarwrap"><div class="subnavbarcontainer"><div id="subnavbar"><div id="subnavbarbackground"><div id="menu-b-menu"><nav role="navigation" aria-label="Main Menu"><div class="menu-bottom-menu-container"><ul id="menu-bottom-menu" class="sf-menu sno-bottom-menu" role="menubar"><li id="menu-item-211" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-211"><a href="https://www.torchonline.com/category/news/">News</a></li>
<li id="menu-item-2229873" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2229873"><a href="https://www.torchonline.com/category/sports/">Sports</a></li>
<li id="menu-item-213" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-213"><a href="https://www.torchonline.com/category/features/">Features</a></li>
<li id="menu-item-2229874" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2229874"><a href="https://www.torchonline.com/category/entertainment/">Entertainment</a></li>
<li id="menu-item-212" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-212"><a href="https://www.torchonline.com/category/opinion/">Opinion</a></li>
</ul></div></nav></div><ul id='menu-more-bottom' class='sf-menu sf-js-enabled sf-shadow' style='display:none'><li id="menu-more-item-bottom" style="float:left;"><a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"> »</span></a>
						<ul id="add-more-bottom" class="sub-menu"></ul>
						</li>
					</ul></div></div></div></div></div><div class="clear"></div><script type="text/javascript">
					$(window).load(function() {
						if ($( window).width() < 980) { return; }
						resizeMenuBottom();
					})
					
					function resizeMenuBottom() {
						if ($( window).width() < 980) { return; }
						var moreWidth = 0; var menubuffer = 0; var minilogo = 0;
						if ($('#menu-more-bottom').is(':visible')) { moreWidth = $('#menu-more-bottom').width(); }			
																															var MenuBottomWidth = 970;
												if (($('#menu-b-menu').width() + menubuffer + minilogo + moreWidth) > MenuBottomWidth) 
						{ 
							$('.sno-bottom-menu > li:last-child').addClass('sub-menu'); 
							$('.sno-bottom-menu > li:last-child').appendTo('#add-more-bottom'); 
							if ($('#menu-more-bottom').is(':hidden')) { $('#menu-more-bottom').css({display: "block"}); }			
							if (($('#menu-b-menu').width() + menubuffer + minilogo + moreWidth) > MenuBottomWidth) resizeMenuBottom(); 
						} 
						 
					}
					$( window ).scroll(function() {
						if ($( window).width() < 980) { return; }
						resizeMenuBottom();
					
					});
            		$( window ).resize(function() { 
             	   		if ($( window).width() > 980) { resizeMenuBottom(); };
            		});   
 				</script>				<script type="text/javascript">
					$(document).ready(function() {
						$(".newsticker3-jcarousellite").jCarouselLite({
        					vertical: true,
        					visible: 1,
        					auto:3000,
        					speed:1300    					});
					});
				</script><div id="fullwrap" style="position:relative;"><div class="innerbackgroundwrap"><div class="innerbackground"><div id="classic_story"><div id="content"><div id='contentleft'><div class="postarea"><h1 class="storyheadline">PLUG Ticket Sweeps SGI Elections</h1><div class="photowrap"><a class='modal-photosingle2236293' href='#photo'><img src='https://www.torchonline.com/wp-content/uploads/2018/03/IMG_1888.png' alt='' style='width:100%' class='catboxphoto feature-image' /></a><div class='modal-photosingle2236293 photo-enlarge elusive el-icon-zoom-in'></div><div class='remodal remodal-story-image' data-remodal-id='modal-photosingle2236293' data-remodal-options='hashTracking: false, closeOnConfirm: false'><button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close</span></button><div class='single-photo-container single-photo-containersingle2236293'><img id="imagesingle2236293" src="https://www.torchonline.com/wp-content/uploads/2018/03/IMG_1888.png" alt="" class="enlarged-photo" /></div><div class="caption-container"><p class='photocaptionremodal'></p><p class='photocreditremodal'></p></div></div><script type="text/javascript">
												$(document).ready(function() {
													$(function(){
														$(".modal-photosingle2236293").click(function() {
															var inst = $("[data-remodal-id=modal-photosingle2236293]").remodal();
															inst.open();
															var slideshow_area_heightsingle2236293 = $('.single-photo-container').height(); 
															var photo_heightsingle2236293 = 768;
													
															if (photo_heightsingle2236293 < slideshow_area_heightsingle2236293 ) {
																var top_marginsingle2236293 = (slideshow_area_heightsingle2236293 - photo_heightsingle2236293)/2;
																$('#imagesingle2236293').css("margin-top", top_marginsingle2236293);
															}
														});
													});
													$('.feature-image').hover(function(){
														$('.photo-enlarge').css("background", "#cc0000");
													}, function(){
														$('.photo-enlarge').css("background", "none");
													});

												});
										</script></div><div class="clear"></div><div class="photobottom"></div><div class="clear"></div><div class="permalinkphotobox"></div><div class="storydetails"><p><span class="storybyline"> <a href="https://www.torchonline.com/about/staff/?writer=Nick%20Bello">Nick Bello</a>, Social Media Manager</span><br /><span class="storydate"><span class="time-wrapper">April 11, 2018</span></span><br /><span class="storycategory">Filed under <a href="https://www.torchonline.com/category/home-scroll/" rel="category tag">Home Scroll</a>, <a href="https://www.torchonline.com/category/news/" rel="category tag">News</a></span></p></div><script type="text/javascript">
					$(function () {
						$('.commentscroll').click(function () {
						var adjustment = 70;
																			adjustment += $('.subnavbarwrap').height();
												$('html, body').animate({ scrollTop: $("#commentswrap").offset().top - adjustment }, 500);
						return false;
						});
					});
				</script><div class="sharing sharing-top"><a class='commentscroll' href='https://www.torchonline.com/news/2018/04/11/plug-ticket-sweeps-sgi-elections/#respond'><div class='sharing-icon sno-comments fa fa-comments-o sno-dark  sharing-mobile-hide'></div></a><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.torchonline.com%2Fnews%2F2018%2F04%2F11%2Fplug-ticket-sweeps-sgi-elections%2F" title="Share on Facebook" target="_blank"><div aria-hidden="true" class="sharing-icon sharing-mobile sno-facebook dashicons dashicons-facebook-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=PLUG+Ticket+Sweeps+SGI+Elections&amp;url=https%3A%2F%2Fwww.torchonline.com%2F%3Fp%3D2236293&amp;via=SJUTorch" title="Tweet This Story" target="_blank"><div aria-hidden="true" class="sharing-icon sharing-mobile sno-twitter dashicons dashicons-twitter sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Twitter</span></div></a><a aria-hidden="true" data-remodal-target="modal"><div class="sharing-icon sno-email dashicons dashicons-email-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share via Email</span></div></a></div>			<script type="text/javascript">
				$(document).ready(function() {
					$(function(){
						$('.modal-share').click(function() {
							var inst = $('[data-remodal-id=modal-share]').remodal();
							inst.open();

							var sharestoryid = '2236293';

							$.ajax({
	                			url:"/wp-admin/admin-ajax.php",
								type:'POST',
								data:'action=sharestory&sharestoryid=' + sharestoryid,
								success:function(results)
	            					{ $("#suggestedstories").replaceWith(results); }
	           				});

						});
										
					});
				});
			</script>

			<div class="remodal" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false">
  				<button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button>
  				<div id="suggestedstories">
  				<h1>Hang on for a minute...we're trying to find some more stories you might like.</h1>
  				<form method="post" action="">

  				<br />
  				<button data-remodal-action="cancel" class="remodal-cancel">Close</button>

  				</form>
  				</div>
			</div>

					<div class="remodal" data-remodal-id="modal" data-remodal-options="hashTracking: false, closeOnConfirm: false">
  				<button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button>
  				<div id="emailstoryform">
  				<h1>Email This Story</h1>
  				<form method="post" action="">
  				<label for="email_to_Above" style="display:none;">Send email to this address</label>
  				<input type="text" id="email_to_Above" name="email_to_Above" class="sno_email_fields" placeholder="Send email to this address"><br />
  				
  				<label for="email_from_Above" style="display:none;">Enter Your Name</label>
  				<input type="text" id="email_from_Above" name="email_from_Above" class="sno_email_fields" placeholder="Enter Your Name"><br />
  				
  				<label for="email_comment_Above" style="display:none;">Add a comment here</label>
  				<textarea rows="4" id="email_comment_Above" name="email_comment_Above" class="sno_email_fields" placeholder="Add a comment here (optional)."></textarea><br />
  				
  				<label for="human_Above" style="display:none;">Verification</label>
  				<input type="text" id="human_Above" name="human_Above" class="sno_email_fields" placeholder="What's 4 + 10?"><br />

  				<br />
  				<button id="submit_email_Above" data-remodal-action="confirm" class="remodal-confirm">Send Email</button>
  				<button data-remodal-action="cancel" class="remodal-cancel">Cancel</button>
  				<input type="hidden" id="sno_email_submission_form" name="sno_email_submission_form" value="ada700d0ca" /><input type="hidden" name="_wp_http_referer" value="/news/2018/04/11/plug-ticket-sweeps-sgi-elections/" />
  				</form>
  				</div>
			</div>
										<script>
								$(document).ready(function() {

								$(function(){
           							$('#submit_email_Above').click(function(){
											var storyid = '2236293';
											var datastring = '';
											if ($("#email_to_Above").length > 0){
												var email_to = $('input[name=email_to_Above]');
												datastring += '&email_to=' + encodeURIComponent(email_to.val());
       										}

											if ($("#email_from_Above").length > 0){
												var email_from = $('input[name=email_from_Above]');
												datastring += '&email_from=' + encodeURIComponent(email_from.val());
       										}

											if ($("#email_comment_Above").length > 0){
												var email_comment = $('textarea[name=email_comment_Above]');
												datastring += '&email_comment=' + encodeURIComponent(email_comment.val());
       										}

											if ($("#human_Above").length > 0){
												var human = $('input[name=human_Above]');
												datastring += '&human=' + encodeURIComponent(human.val());
       										}
       										
	   										datastring += '&humanity=' + 14;

       										var verification = $('input[name=sno_email_submission_form]');
	   										datastring += '&verification=' + verification.val();
       										
										//	var parentid = '';
               							$.ajax({
                				            url:"/wp-admin/admin-ajax.php",
                				            type:'POST',
                				            data:'action=emailstory&storyid=' + storyid + datastring,
 	            				            success:function(results)
	            				            { $("#emailstoryform").replaceWith(results); }
	           				    	  	});
	         						});
								});
								});

							</script>

			<span class="storycontent"><div class="pf-content"><p id='graph1'><span style="font-weight: 400;">Student Government Inc.’s executive board elections came to a close Friday afternoon with the PLUG ticket coming out on top with a sweep. </span></p>
<p id='graph2'><span style="font-weight: 400;">PLUG, which stands for personality, legacy, unity and growth, was led by junior Atem Tazi who beat out Roderick Jackson 1314 votes to 929. </span><span style="font-weight: 400;">With the win, Tazi becomes the second black female president in SGI history.</span></p>
<p id='graph3'><span style="font-weight: 400;">“I feel honored and humbled,” Tazi said, following the announcement. “It’s been a year-long process and just to be here is so fulfilling.”</span></p>
<p id='graph4'><span style="font-weight: 400;">Jackson, from the SEED ticket, declined to comment on the election results.</span></p>
<p id='graph5'><span style="font-weight: 400;">Tazi will be accompanied by Christopher Stevens who will serve as vice president after defeating current secretary Alissa Santolo 1283 votes  to 950 votes. </span></p>
<p id='graph6'><span style="font-weight: 400;">Stevens said the first thing he wants to accomplish in office is revamping the organization committees.</span></p>
<p id='graph7'><span style="font-weight: 400;">“The committees are what make up SGI.” Stevens said. “Putting the right people in place to put them in a position to be successful and then overseing them and holding them accountable is definitely my first initiative.”</span></p>
<p id='graph8'><span style="font-weight: 400;">Tazi said she is excited to work with the same people she started her journey with. Over these past few months the candidates on the PLUG ticket have formed an almost family like relationship, she said.</span></p>
<p id='graph9'><span style="font-weight: 400;">“We’re really just one big family,” Tazi said. “We have so many plans.”</span></p>
<p id='graph10'><span style="font-weight: 400;">One plan that PLUG wants to implement is a way for students to use meal points at off campus restaurants. The architect of this plan is Henry Stitzel, who will serve as treasurer after defeating Torrent Cannon 1318 votes to 925 votes.</span></p>
<p id='graph11'><span style="font-weight: 400;">“I’m excited,” Stitzel said. “We have a lot of good plans and now it’s time to really act.”</span></p>
<p id='graph12'><span style="font-weight: 400;">Clare Soria will take over as secretary after she defeated Stefanie Bassaragh 1309 votes to 934 votes. Soria was overcome with happiness after the results were announced.</span></p>
<p id='graph13'><span style="font-weight: 400;">“I’m elated,” Soria laughed. “We’ve really become such a tight knit group.”</span></p>
<p id='graph14'><span style="font-weight: 400;">PLUG took all three senate seats as well. These positions represent the sophomore, junior, and senior classes.</span></p>
<p id='graph15'><span style="font-weight: 400;">Noel Bell won the senior senator race over Anthony Romeo winning 985 votes to 863 votes. Johnny Wiley defeated Kristen Labruna 1066 votes to 721 votes in the race for junior senator. And Amel Viaud won the sophomore senator race after she defeated Carley Germain and Hannah Sesay. She received 813 votes. </span></p>
<p id='graph16'><span style="font-weight: 400;">“I’m very proud of both tickets this year,” Frank Obermeyer, the current president of SGI, said. “I respect the work that these students put in and I can’t wait to see what the PLUG ticket will do once in office.”</span></p>
<div class="printfriendly pf-alignleft"><a href="#" rel="nofollow" onclick="window.print(); return false;" class="noslimstat" title="Printer Friendly, PDF & Email"><img style="border:none;-webkit-box-shadow:none; box-shadow:none;" src="https://cdn.printfriendly.com/buttons/print-button.png" alt="Print Friendly, PDF & Email" /></a></div></div></p><div id="story_bottom"></div></span><div class="clear"></div><div class="postmeta"><p><span class="tags sno">Tags: <a href="https://www.torchonline.com/tag/plug/" rel="tag">PLUG</a>, <a href="https://www.torchonline.com/tag/sgi/" rel="tag">SGI</a>, <a href="https://www.torchonline.com/tag/sgi-elections/" rel="tag">SGI Elections</a>, <a href="https://www.torchonline.com/tag/student-government-inc/" rel="tag">Student Government Inc.</a></span></p></div></div><script>
        		$(document).ready(function() {
    				$("#commentsbox").click(function() {
    			    	$("#commentsbody").slideToggle('slow');
    			    	$("#expand").toggle();
    			    	$("#collapse").toggle();
    				});
				});				
        		$(document).ready(function() {
    				$("#commentslink").click(function() {
    			    	$("#commentsbody").slideDown('slow');
    			    	$("#expand").hide();
    			    	$("#collapse").show();
    				});
				});				
			</script><div id="comments" class="sno-animate" style="height:60px;display:block"></div><div class="clear"></div><div id="commentswrap"><div class="widgetwrap"><div class="titlewrap cursorpoint" id="commentsbox"><div id="expand"><div class="fa fa-plus-square"></div></div><div id="collapse"><div class="fa fa-minus-square"></div></div><div class="widgettitle-nonsno">Leave a Comment</div></div><div id="commentsbody" class="widgetbody">


<!-- You can start editing here. -->



<div id="commentblock">




	
		<!-- If comments are open, but there are no comments. -->



	 








<p id="respond">
We love comments and feedback, but we ask that you please be respectful in your responses.<br /><br />
If you want a picture to show with your comment, go get a <a href="http://en.gravatar.com" >gravatar</a>.</p>





<form action="https://www.torchonline.com/wp-comments-post.php" method="post" id="commentform">






<p><label for="name">Name (required)</label><br />

<input type="text" name="author" id="name" value="" size="50" tabindex="1" /></p>



<p><label for="email">Email Address (required)</label><br />

<input type="text" name="email" id="email" value="" size="50" tabindex="2" /></p>








<!--<p><small><strong>XHTML:</strong> You can use these tags: </small></p>-->


<div style="display:none"><input type="text" name="sno_is_legit_comment" id="spam_stopper" value="SNO_Spam_Stopper"/></p></div>

	             		<script type="text/javascript">
							$(function(){
								$('input[name="sno_is_legit_comment"]').attr('name', 'sno_stop_spam');
							});
						</script>


<p><label for="words">Speak your mind</label><br /><textarea name="comment" id="words" cols="40" rows="10" tabindex="4"></textarea></p>



<p><input name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" />

<input type="hidden" name="comment_post_ID" value="2236293" /></p>



<p><input type="hidden" id="comment_reply_ID" name="comment_reply_ID" value="0" /><input type="hidden" id="comment_reply_dp" name="comment_reply_dp" value="0" /></p><div id="cancel_reply" style="display:none;"><a href="javascript:void(0)" onclick="movecfm(null,0,1,null);" style="color:red;">Click to cancel reply</a></div><script type="text/javascript">
/* <![CDATA[ */
var commentformid = "commentform";
var USERINFO = false;
var atreply = "none";
/* ]]> */
</script>
<script type="text/javascript" src="https://www.torchonline.com/wp-content/plugins/wordpress-thread-comment/wp-thread-comment.js.php?jsver=common"></script>



</form>









</div></div><div class="widgetfooter"></div></div></div></div><div id="sidebar"><div class='widgetwrap sno-animate' style=''><div class="widget1 widgettitle" style="background: #ee2827!important;color:#ffffff !important;border-left:2px solid #ee2827 !important;border-right:2px solid #ee2827 !important;border-top:2px solid #ee2827 !important;font-size:22px !important;line-height:32px !important;text-align:left;">Trending Stories</div><div class="widgetbody1" style="background-color:#ffffff !important;border-right:2px solid #ee2827 !important;border-left:2px solid #ee2827 !important;border-bottom:2px solid #ee2827 !important;">
<!-- widget displayed from cache -->
<div class='trending-row' style='border-top: 1px solid #dd0000;border-bottom: 1px solid #dd0000;margin-bottom: -1px;'><div class="trending-number">1</div><p><a class="homeheadline" href="https://www.torchonline.com/sports/2018/03/23/the-future-of-st-johns-at-madison-square-garden/">The Future of St. John&#8217;s at Madison Square Garden</a><span class="trending-views"> &bull; 844 Views</span></p><div class="clear"></div></div><div class='trending-row' style='border-top: 1px solid #dd0000;border-bottom: 1px solid #dd0000;margin-bottom: -1px;'><div class="trending-number">2</div><p><a class="homeheadline" href="https://www.torchonline.com/sports/2018/04/05/yakwe-leaves-st-johns-are-ponds-and-owens-next/">Yakwe Leaves St. John&#8217;s. Are Ponds and Owens Next?</a><span class="trending-views"> &bull; 446 Views</span></p><div class="clear"></div></div><div class='trending-row' style='border-top: 1px solid #dd0000;border-bottom: 1px solid #dd0000;margin-bottom: -1px;'><div class="trending-number">3</div><p><a class="homeheadline" href="https://www.torchonline.com/opinion/2018/03/14/call-me-by-your-name-isnt-helping-lgbt-relationships/">&#8220;Call Me by Your Name&#8221; Isn&#8217;t Helping LGBT Relationships</a><span class="trending-views"> &bull; 212 Views</span></p><div class="clear"></div></div><div class="widget-expander" style="padding-bottom:4px"></div><div class="clear"></div>

</div>

				
		
		</div>



				
<div class='widgetwrap sno-animate' style=''>			
						<div class="widgetbody3" >			<div class="advertisementwrap" style="margin:0px auto;max-width:100%">
				<a target="_blank" href="/subscriptions"><img src="https://www.torchonline.com/wp-content/uploads/2016/09/subscribe.jpg"  alt="Subscribe" class="centered" style="max-width:100%" /></a>
			</div>
			</div><div class="clear"></div></div><div class='widgetwrap sno-animate' style=''>			
						<div class="widgetbody3" >			<div class="advertisementwrap" style="margin:0px auto;max-width:100%">
				<a target="_blank" href="https://www.torchonline.com/?page_id=2231836&preview=true"><img src="https://www.torchonline.com/wp-content/uploads/2016/08/pitchtous-1.jpg"  alt="Pitch to us!" class="centered" style="max-width:100%" /></a>
			</div>
			</div><div class="clear"></div></div><div style="clear:both"></div><div class="widget_text widgetwrap sno-animate"><div><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Automatic -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1224319487021977"
     data-ad-slot="3250733857"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><div class="widgetfooter3"></div></div><div style="clear:both"></div><div class="widget_text widgetwrap sno-animate"><div><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Automatic -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1224319487021977"
     data-ad-slot="3250733857"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><div class="widgetfooter3"></div></div><div style="clear:both"></div><div class="widget_text widgetwrap sno-animate"><div><div class="textwidget custom-html-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Automatic -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1224319487021977"
     data-ad-slot="3250733857"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><div class="widgetfooter3"></div></div></div></div></div><div class="sno_teaserbar" id="sno_teaserbar"><div class="stb_nav"><div class="custom-navigation"><span class="flex-next"><div class="stb_right"><div class="dashicons dashicons-arrow-right"><div class="icon-hidden-text">Navigate Right</div></div></div></span><span class="flex-prev"><div class="stb_left"><div class="dashicons dashicons-arrow-left"><div class="icon-hidden-text">Navigate Left</div></div></div></span></div></div><div id='stb-container' class='flexslider'><ul class="slides"><li class='stb-top-row'><div class='stb_image'><a href='https://www.torchonline.com/features/2018/04/04/theyre-putting-money-over-humans/#photo'><img src='https://www.torchonline.com/wp-content/uploads/2018/04/Ashlande1-475x317.jpg' id='grow-stb2236279'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='PLUG Ticket Sweeps SGI Elections'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb2236279').mouseenter(function() {
   											$('#grow-stb2236279').removeClass('shrink');
   											$('#grow-stb2236279').removeClass('grow');
   											$('#grow-stb2236279').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb2236279').addClass('shrink');
   										});});</script><p class='stb-cat'>Features</p><p class="relatedtitle"><a href="https://www.torchonline.com/features/2018/04/04/theyre-putting-money-over-humans/">“They’re Putting Money Over Humans”</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.torchonline.com/features/2018/04/04/globe-education-beyond-the-classroom/#photo'><img src='https://www.torchonline.com/wp-content/uploads/2018/04/GLOBEPIC2-475x317.jpg' id='grow-stb2236269'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='PLUG Ticket Sweeps SGI Elections'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb2236269').mouseenter(function() {
   											$('#grow-stb2236269').removeClass('shrink');
   											$('#grow-stb2236269').removeClass('grow');
   											$('#grow-stb2236269').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb2236269').addClass('shrink');
   										});});</script><p class='stb-cat'>Features</p><p class="relatedtitle"><a href="https://www.torchonline.com/features/2018/04/04/globe-education-beyond-the-classroom/">GLOBE: Education Beyond the Classroom</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.torchonline.com/news/2018/04/04/two-months-later-gempesaw-talks-town-hall/#photo'><img src='https://www.torchonline.com/wp-content/uploads/2018/04/bobbyg-317x475.jpg' id='grow-stb2236237'  style='width:70px;min-width:70px;' class='catboxphoto' alt='PLUG Ticket Sweeps SGI Elections'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb2236237').mouseenter(function() {
   											$('#grow-stb2236237').removeClass('shrink');
   											$('#grow-stb2236237').removeClass('grow');
   											$('#grow-stb2236237').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb2236237').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://www.torchonline.com/news/2018/04/04/two-months-later-gempesaw-talks-town-hall/">Two Months Later, Gempesaw Talks Town Hall</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.torchonline.com/news/2018/04/04/student-government-debate-talks-2018-19-goals/#photo'><img src='https://www.torchonline.com/wp-content/uploads/2018/04/sgi-panel-475x317.jpg' id='grow-stb2236234'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='PLUG Ticket Sweeps SGI Elections'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb2236234').mouseenter(function() {
   											$('#grow-stb2236234').removeClass('shrink');
   											$('#grow-stb2236234').removeClass('grow');
   											$('#grow-stb2236234').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb2236234').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://www.torchonline.com/news/2018/04/04/student-government-debate-talks-2018-19-goals/">Student Government Debate Talks 2018-19 Goals</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.torchonline.com/news/2018/03/21/school-safety/#photo'><img src='https://www.torchonline.com/wp-content/uploads/2018/03/FRONT_PAGE-475x380.jpg' id='grow-stb2236145'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='PLUG Ticket Sweeps SGI Elections'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb2236145').mouseenter(function() {
   											$('#grow-stb2236145').removeClass('shrink');
   											$('#grow-stb2236145').removeClass('grow');
   											$('#grow-stb2236145').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb2236145').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://www.torchonline.com/news/2018/03/21/school-safety/">School Safety</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.torchonline.com/features/2018/03/21/sustaining-the-future/#photo'><img src='https://www.torchonline.com/wp-content/uploads/2018/03/SUSTAIN-LOGO-475x382.png' id='grow-stb2236175'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='PLUG Ticket Sweeps SGI Elections'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb2236175').mouseenter(function() {
   											$('#grow-stb2236175').removeClass('shrink');
   											$('#grow-stb2236175').removeClass('grow');
   											$('#grow-stb2236175').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb2236175').addClass('shrink');
   										});});</script><p class='stb-cat'>Features</p><p class="relatedtitle"><a href="https://www.torchonline.com/features/2018/03/21/sustaining-the-future/">Sustaining the Future</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.torchonline.com/entertainment/2018/03/21/coffee-conversations-arisa-ossandon-talks-art-and-creativity/#photo'><img src='https://www.torchonline.com/wp-content/uploads/2018/03/Torch-Photo_Carolina-Rodriguez-475x356.jpg' id='grow-stb2236157'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='PLUG Ticket Sweeps SGI Elections'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb2236157').mouseenter(function() {
   											$('#grow-stb2236157').removeClass('shrink');
   											$('#grow-stb2236157').removeClass('grow');
   											$('#grow-stb2236157').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb2236157').addClass('shrink');
   										});});</script><p class='stb-cat'>Entertainment</p><p class="relatedtitle"><a href="https://www.torchonline.com/entertainment/2018/03/21/coffee-conversations-arisa-ossandon-talks-art-and-creativity/">Coffee Conversations: Arisa Ossandon Talks Art and Creativity</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.torchonline.com/news/2018/03/21/adding-to-the-clothesline-narrative/#photo'><img src='https://www.torchonline.com/wp-content/uploads/2018/03/art-2-e1521649710236-356x475.jpg' id='grow-stb2236134'  style='width:70px;min-width:70px;' class='catboxphoto' alt='PLUG Ticket Sweeps SGI Elections'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb2236134').mouseenter(function() {
   											$('#grow-stb2236134').removeClass('shrink');
   											$('#grow-stb2236134').removeClass('grow');
   											$('#grow-stb2236134').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb2236134').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://www.torchonline.com/news/2018/03/21/adding-to-the-clothesline-narrative/">Adding to the Clothesline Narrative</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.torchonline.com/news/2018/03/14/union-utopia-accident-reports-increase/#photo'><img src='https://www.torchonline.com/wp-content/uploads/2018/03/UNION-INSIDE-475x317.jpg' id='grow-stb2236047'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='PLUG Ticket Sweeps SGI Elections'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb2236047').mouseenter(function() {
   											$('#grow-stb2236047').removeClass('shrink');
   											$('#grow-stb2236047').removeClass('grow');
   											$('#grow-stb2236047').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb2236047').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://www.torchonline.com/news/2018/03/14/union-utopia-accident-reports-increase/">Union/Utopia Accident Reports Increase</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.torchonline.com/news/2018/03/14/womens-herstory-distinction-dinner/#photo'><img src='https://www.torchonline.com/wp-content/uploads/2018/03/WOMENS-DISTINCTION-2-e1521053420854-317x475.jpg' id='grow-stb2236041'  style='width:70px;min-width:70px;' class='catboxphoto' alt='PLUG Ticket Sweeps SGI Elections'/></a></div><script type='text/javascript'>
									$(document).ready(function() {
   								 		$('#grow-stb2236041').mouseenter(function() {
   											$('#grow-stb2236041').removeClass('shrink');
   											$('#grow-stb2236041').removeClass('grow');
   											$('#grow-stb2236041').addClass('grow');
   										}).mouseleave(function() {
   											$('#grow-stb2236041').addClass('shrink');
   										});});</script><p class='stb-cat'>News</p><p class="relatedtitle"><a href="https://www.torchonline.com/news/2018/03/14/womens-herstory-distinction-dinner/">Women&#8217;s Herstory Distinction Dinner</a></p></li></ul></div></div><div class="clear"></div><script type="text/javascript" charset="utf-8">
		$(document).ready(function() {
			$('#stb-container').flexslider({
				animation: "slide",
				animationLoop: true,
				customDirectionNav: $(".custom-navigation span"), 
       			slideshow: false,
				itemMargin: 1,
				touch: true,
				itemWidth: 250,
				minItems: 1,
				move: 1,
				maxItems: 5
  			});

  							//		animation: 'fade',
  							//		smoothHeight: false,
  							//		customDirectionNav: $("#sfi-navigation span"),
  							//		animationLoop: true,
  							//		slideshow: false,
  							//		touch: true



		});

			$(document).ready(function(){
			
			var TB_CurrentScroll = 0; var TB_NextScroll = 0; var hbheight = 0;
			
			
			$(window).scroll(function(event) {
				TB_CurrentScroll = TB_NextScroll;
				if ($('#sno_hoverbar').is(":visible")) { hbheight = 50 }
				TB_NextScroll = $(this).scrollTop();
				if (TB_NextScroll < TB_CurrentScroll && $(document).scrollTop() > 500) {  // scrolling up on the page causes it to display
					if ($('.sno_teaserbar').is(":hidden")) {
						$('.sno_teaserbar').show();
						$('.sno_teaserbar').stop().animate({ top: hbheight }, { duration: 300, queue: false });
					}
				}
				 else if ((TB_NextScroll > TB_CurrentScroll && $(document).scrollTop() > 500) || $(document).scrollTop() < 400 ){ // scrolling down on the page causes it to hide
					$('.sno_teaserbar').stop().animate({
						top: '-80px'
						},200, function(){
							$('.sno_teaserbar').hide();
						});
				} 
			});
								$('#sno_teaserbar').hover(function(){
				$('.stb_right').css("color", "#aaa");
				$('.stb_left').css("color", "#aaa");
				$('.stb_right').css("border-color", "#aaa");
				$('.stb_left').css("border-color", "#aaa");
				$('.stb_right').hover(function(){
					$('.stb_right').css("color", "#cc0000");
					$('.stb_right').css("border-color", "#cc0000");
				}, function(){
					$('.stb_right').css("color", "#aaa");
					$('.stb_right').css("border-color", "#aaa");
				})
				$('.stb_left').hover(function(){
					$('.stb_left').css("color", "#cc0000");
					$('.stb_left').css("border-color", "#cc0000");
				}, function(){
					$('.stb_left').css("color", "#aaa");
					$('.stb_left').css("border-color", "#aaa");
				})
			}, function(){
				$('.stb_right').css("color", "#ddd");
				$('.stb_left').css("color", "#ddd");
				$('.stb_right').css("border-color", "#ddd");
				$('.stb_left').css("border-color", "#ddd");
			})
		});
	</script></div></div></div><div style="clear:both;"></div><div class="footerwrap"><div id="footer"><div class="footername"><div class="footerleft"><p><a href="https://www.torchonline.com">The Torch</a></p></div><div class="footerright social-classic"><style>.topnavbarleft { padding: 0px; width:auto; }</style><a aria-hidden="true" target="_blank" href="https://www.youtube.com/channel/UC27raD8kuNmoCAfG6Q3I3uw">
        		<div class="alt-header-social-fa social-border sno-youtube fa fa-youtube"><span class="icon-hidden-text">YouTube</span></div>
        	</a><a aria-hidden="true" target="_blank" href="https://www.instagram.com/sju_torch/">
        		<div class="alt-header-social-fa social-border sno-instagram fa fa-instagram"><span class="icon-hidden-text">Instagram</span></div>
        	</a><a aria-hidden="true" target="_blank" href="https://twitter.com/sjutorch?lang=en">
        		<div class="alt-header-social social-border sno-twitter dashicons dashicons-twitter"><span class="icon-hidden-text">Twitter</span></div>
        	</a><a aria-hidden="true" target="_blank" href="https://www.facebook.com/STJTorch/?fref=ts">
        		<div class="alt-header-social social-border sno-facebook dashicons dashicons-facebook-alt"><span class="icon-hidden-text">Facebook</span></div>
        	</a><div class="social-spacer"></div></div></div><div class="footertagline"><p>The Independent Student Newspaper of St. John&#039;s University</p></div><div class="footersearch">	<form method="get" id="searchform9053" action="https://www.torchonline.com/">
			<label for="s9053" class="assistive-text">Search</label>
			<div class="search-button-container" id="searchthis9053">
			<button type="submit" disabled="disabled" id="sno-search-navbar-9053" class="sno-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
			<input type="text" class="field s" name="s" id="s9053" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit9053" style="display:none;" value="Search" />
		</form>
	</div><div class="clear"></div><div class="footercredit"><p>&copy; 2018  &bull; <a target='_blank' href='https://snosites.com/client-site-privacy-policy/'>Privacy Policy</a> &bull; <a href='https://snosites.com/why-sno/'>FLEX WordPress Theme</a> by <a href='http://snosites.com'>SNO</a> &bull; <a href="https://www.torchonline.com/wp-login.php">Log in</a></p></div><div class="clear"></div></div></div><script type="text/javascript">
// start of scroll to view

$(document).ready(function() {
	
	$("a[href='#slideshow']").on('click', function(event) { return false; });
	$("a[href='#photo']").on('click', function(event) { return false; });

var win = $(window);
var allMods = $(".sno-animate");
var allWPcaptions = $(".wp-caption");

// Already visible modules
allMods.each(function(i, el) {
  var el = $(el);
  if (el.visible(true)) {
    el.addClass("already-visible"); 
  } 
else {
  /*  Like this!  */
  el.css('visibility', 'hidden');
  }
});
allWPcaptions.each(function(i, el) {
  var el = $(el);
  if (el.visible(true)) {
    el.addClass("already-visible"); 
  } 
});


$(window).scroll(function(event) {
  
  $(".sno-animate").each(function(i, el) {
    var el = $(el);
    if (el.visible(true)) {
      	el.addClass("come-in");     
	    el.css('visibility', 'visible'); // Visible
    } 
  });
  $(".wp-caption").each(function(i, el) {
    var el = $(el);
    if (el.visible(true)) {
      	el.addClass("come-in");     
	    el.css('visibility', 'visible'); // Visible
    } 
  });
  
});


});
//end of scroll to view
</script>
<script type="text/javascript">
	$(function(){
		$(".s").focus(function(){
			$(".sno-submit-search-button").prop("disabled", false);
		});				
	});
    var top_level_links = $(".sf-menu").find('> li > a');
    // Set tabIndex to -1 so that top_level_links can't receive focus until menu is open
    $(top_level_links).next('ul')
        .attr({ 'aria-hidden': 'true', 'role': 'menu' })
        .find('a')
            .attr('tabIndex',-1);

    // Adding aria-haspopup for appropriate items
    $(top_level_links).each(function(){
        if($(this).next('ul').length > 0)
            $(this).parent('li').attr('aria-haspopup', 'true');
    });
   
jQuery( function() {
 	jQuery( '#hover-menu-side' ).on( 'touchstart click', function(e) {
 		e.preventDefault();
 			$('#sno_mobile_menu').fadeToggle();

 	});
 	jQuery( '.side-close-icon' ).on( 'touchstart click', function(e) {
 		e.preventDefault();
 			$('#sno_mobile_menu').fadeToggle();

 	});
 		
});

</script>
		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-22842225-9', 'auto');
			ga('require', 'displayfeatures');
			ga('send', 'pageview');
		</script> 	
		
	      <script type="text/javascript">

          var pfHeaderImgUrl = '';
          var pfHeaderTagline = '';
          var pfdisableClickToDel = '0';
          var pfImagesSize = 'full-size';
          var pfImageDisplayStyle = 'right';
          var pfDisableEmail = '0';
          var pfDisablePDF = '0';
          var pfDisablePrint = '0';
          var pfCustomCSS = '';
          var pfPlatform = 'Wordpress';
      (function() {
            var e = document.createElement('script'); e.type="text/javascript";
            e.src = 'https://cdn.printfriendly.com/printfriendly.js';
            document.getElementsByTagName('head')[0].appendChild(e);
        })();
      </script>
<link rel='stylesheet' id='fm-jquery-ui-css'  href='https://www.torchonline.com/wp-content/plugins/form-maker/css/jquery-ui.custom.css?ver=1.12.21' type='text/css' media='all' />
<link rel='stylesheet' id='fm-frontend-css'  href='https://www.torchonline.com/wp-content/plugins/form-maker/css/form_maker_frontend.css?ver=1.12.21' type='text/css' media='all' />
<link rel='stylesheet' id='fm-googlefonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans|Oswald|Droid+Sans|Lato|Open+Sans+Condensed|PT+Sans|Ubuntu|PT+Sans+Narrow|Yanone+Kaffeesatz|Roboto+Condensed|Source+Sans+Pro|Nunito|Francois+One|Roboto|Raleway|Arimo|Cuprum|Play|Dosis|Abel|Droid+Serif|Arvo|Lora|Rokkitt|PT+Serif|Bitter|Merriweather|Vollkorn|Cantata+One|Kreon|Josefin+Slab|Playfair+Display|Bree+Serif|Crimson+Text|Old+Standard+TT|Sanchez|Crete+Round|Cardo|Noticia+Text|Judson|Lobster|Unkempt|Changa+One|Special+Elite|Chewy|Comfortaa|Boogaloo|Fredoka+One|Luckiest+Guy|Cherry+Cream+Soda|Lobster+Two|Righteous|Squada+One|Black+Ops+One|Happy+Monkey|Passion+One|Nova+Square|Metamorphous|Poiret+One|Bevan|Shadows+Into+Light|The+Girl+Next+Door|Coming+Soon|Dancing+Script|Pacifico|Crafty+Girls|Calligraffitti|Rock+Salt|Amatic+SC|Leckerli+One|Tangerine|Reenie+Beanie|Satisfy|Gloria+Hallelujah|Permanent+Marker|Covered+By+Your+Grace|Walter+Turncoat|Patrick+Hand|Schoolbell|Indie+Flower&#038;subset=greek,latin,greek-ext,vietnamese,cyrillic-ext,latin-ext,cyrillic' type='text/css' media='all' />
<link rel='stylesheet' id='fm-animate-css'  href='https://www.torchonline.com/wp-content/plugins/form-maker/css/fm-animate.css?ver=1.12.21' type='text/css' media='all' />
<script type='text/javascript' src='https://www.torchonline.com/wp-content/plugins/prettyphoto-media/js/jquery.prettyPhoto.min.js?ver=3.1.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.torchonline.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.torchonline.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.torchonline.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.0.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.torchonline.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.8'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-includes/js/wp-embed.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-includes/js/jquery/ui/effect.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-includes/js/jquery/ui/effect-shake.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var fm_objectL10n = {"states":{"":"","Alabama":"Alabama","Alaska":"Alaska","Arizona":"Arizona","Arkansas":"Arkansas","California":"California","Colorado":"Colorado","Connecticut":"Connecticut","Delaware":"Delaware","District Of Columbia":"District Of Columbia","Florida":"Florida","Georgia":"Georgia","Hawaii":"Hawaii","Idaho":"Idaho","Illinois":"Illinois","Indiana":"Indiana","Iowa":"Iowa","Kansas":"Kansas","Kentucky":"Kentucky","Louisiana":"Louisiana","Maine":"Maine","Maryland":"Maryland","Massachusetts":"Massachusetts","Michigan":"Michigan","Minnesota":"Minnesota","Mississippi":"Mississippi","Missouri":"Missouri","Montana":"Montana","Nebraska":"Nebraska","Nevada":"Nevada","New Hampshire":"New Hampshire","New Jersey":"New Jersey","New Mexico":"New Mexico","New York":"New York","North Carolina":"North Carolina","North Dakota":"North Dakota","Ohio":"Ohio","Oklahoma":"Oklahoma","Oregon":"Oregon","Pennsylvania":"Pennsylvania","Rhode Island":"Rhode Island","South Carolina":"South Carolina","South Dakota":"South Dakota","Tennessee":"Tennessee","Texas":"Texas","Utah":"Utah","Vermont":"Vermont","Virginia":"Virginia","Washington":"Washington","West Virginia":"West Virginia","Wisconsin":"Wisconsin","Wyoming":"Wyoming"},"plugin_url":"https:\/\/www.torchonline.com\/wp-content\/plugins\/form-maker","form_maker_admin_ajax":"https:\/\/www.torchonline.com\/wp-admin\/admin-ajax.php","fm_file_type_error":"Can not upload this type of file","fm_field_is_required":"Field is required.","fm_min_max_check_1":"The ","fm_min_max_check_2":" value must be between ","fm_spinner_check":"Value must be between ","fm_clear_data":"Are you sure you want to clear saved data?","fm_grading_text":"Your score should be less than","time_validation":"This is not a valid time value.","number_validation":"This is not a valid number value.","date_validation":"This is not a valid date value.","year_validation":"The year must be between %%start%% and %%end%%"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/plugins/form-maker/js/main_div_front_end.js?ver=1.12.21'></script>
<script>
jQuery(function($) {
$('a[rel^="prettyPhoto"]').prettyPhoto({ default_width: 750, default_height: 500 });
});
</script>
</div><div id="sno_hoversearch"><div class="sno-search-close foundation-icons fi-x" style="float:right;"></div><div class="hover-search-area"><form method="get" id="searchform-alt" action="https://www.torchonline.com/">
											<label for="s-alt" class="assistive-text">Search</label>
											<input type="text" class="field" name="s" id="s-alt" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
											<input type="submit" class="submit" name="submit" id="searchsubmit-alt" value="Search" />
											<button type="submit" id="sno-hover-search-button" class="sno-submit-search sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
										</form></div></div><div id="sno_hoverbar"><div class="hoverheader"><div id="search-top"><div aria-hidden="true" class="sno-search-button fa fa-search"><span class="icon-hidden-text">Activate Search</span></div></div><div class="socialmedia"><script type="text/javascript">
					$(function () {
						$('.commentscroll').click(function () {
						var adjustment = 70;
																			adjustment += $('.subnavbarwrap').height();
												$('html, body').animate({ scrollTop: $("#commentswrap").offset().top - adjustment }, 500);
						return false;
						});
					});
				</script><div class="sharing sharing-top"><a class='commentscroll' href='https://www.torchonline.com/news/2018/04/11/plug-ticket-sweeps-sgi-elections/#respond'><div class='sharing-icon sno-comments fa fa-comments-o sno-dark  sharing-mobile-hide'></div></a><a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.torchonline.com%2Fnews%2F2018%2F04%2F11%2Fplug-ticket-sweeps-sgi-elections%2F" title="Share on Facebook" target="_blank"><div aria-hidden="true" class="sharing-icon sharing-mobile sno-facebook dashicons dashicons-facebook-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Facebook</span></div></a><a class="modal-share" href="https://twitter.com/intent/tweet?text=PLUG+Ticket+Sweeps+SGI+Elections&amp;url=https%3A%2F%2Fwww.torchonline.com%2F%3Fp%3D2236293&amp;via=SJUTorch" title="Tweet This Story" target="_blank"><div aria-hidden="true" class="sharing-icon sharing-mobile sno-twitter dashicons dashicons-twitter sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share on Twitter</span></div></a><a aria-hidden="true" data-remodal-target="modal"><div class="sharing-icon sno-email dashicons dashicons-email-alt sno-dark sharing-mobile-hide"><span class="icon-hidden-text">Share via Email</span></div></a></div>			<script type="text/javascript">
				$(document).ready(function() {
					$(function(){
						$('.modal-share').click(function() {
							var inst = $('[data-remodal-id=modal-share]').remodal();
							inst.open();

							var sharestoryid = '2236293';

							$.ajax({
	                			url:"/wp-admin/admin-ajax.php",
								type:'POST',
								data:'action=sharestory&sharestoryid=' + sharestoryid,
								success:function(results)
	            					{ $("#suggestedstories").replaceWith(results); }
	           				});

						});
										
					});
				});
			</script>

			<div class="remodal" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false">
  				<button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button>
  				<div id="suggestedstories">
  				<h1>Hang on for a minute...we're trying to find some more stories you might like.</h1>
  				<form method="post" action="">

  				<br />
  				<button data-remodal-action="cancel" class="remodal-cancel">Close</button>

  				</form>
  				</div>
			</div>

					<div class="remodal" data-remodal-id="modal" data-remodal-options="hashTracking: false, closeOnConfirm: false">
  				<button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button>
  				<div id="emailstoryform">
  				<h1>Email This Story</h1>
  				<form method="post" action="">
  				<label for="email_to_Bar" style="display:none;">Send email to this address</label>
  				<input type="text" id="email_to_Bar" name="email_to_Bar" class="sno_email_fields" placeholder="Send email to this address"><br />
  				
  				<label for="email_from_Bar" style="display:none;">Enter Your Name</label>
  				<input type="text" id="email_from_Bar" name="email_from_Bar" class="sno_email_fields" placeholder="Enter Your Name"><br />
  				
  				<label for="email_comment_Bar" style="display:none;">Add a comment here</label>
  				<textarea rows="4" id="email_comment_Bar" name="email_comment_Bar" class="sno_email_fields" placeholder="Add a comment here (optional)."></textarea><br />
  				
  				<label for="human_Bar" style="display:none;">Verification</label>
  				<input type="text" id="human_Bar" name="human_Bar" class="sno_email_fields" placeholder="What's 5 + 3?"><br />

  				<br />
  				<button id="submit_email_Bar" data-remodal-action="confirm" class="remodal-confirm">Send Email</button>
  				<button data-remodal-action="cancel" class="remodal-cancel">Cancel</button>
  				<input type="hidden" id="sno_email_submission_form" name="sno_email_submission_form" value="ada700d0ca" /><input type="hidden" name="_wp_http_referer" value="/news/2018/04/11/plug-ticket-sweeps-sgi-elections/" />
  				</form>
  				</div>
			</div>
										<script>
								$(document).ready(function() {

								$(function(){
           							$('#submit_email_Bar').click(function(){
											var storyid = '2236293';
											var datastring = '';
											if ($("#email_to_Bar").length > 0){
												var email_to = $('input[name=email_to_Bar]');
												datastring += '&email_to=' + encodeURIComponent(email_to.val());
       										}

											if ($("#email_from_Bar").length > 0){
												var email_from = $('input[name=email_from_Bar]');
												datastring += '&email_from=' + encodeURIComponent(email_from.val());
       										}

											if ($("#email_comment_Bar").length > 0){
												var email_comment = $('textarea[name=email_comment_Bar]');
												datastring += '&email_comment=' + encodeURIComponent(email_comment.val());
       										}

											if ($("#human_Bar").length > 0){
												var human = $('input[name=human_Bar]');
												datastring += '&human=' + encodeURIComponent(human.val());
       										}
       										
	   										datastring += '&humanity=' + 8;

       										var verification = $('input[name=sno_email_submission_form]');
	   										datastring += '&verification=' + verification.val();
       										
										//	var parentid = '';
               							$.ajax({
                				            url:"/wp-admin/admin-ajax.php",
                				            type:'POST',
                				            data:'action=emailstory&storyid=' + storyid + datastring,
 	            				            success:function(results)
	            				            { $("#emailstoryform").replaceWith(results); }
	           				    	  	});
	         						});
								});
								});

							</script>

			</div><div id="back-top"><a id="snotop" href="#top" title="Return to Top"><div aria-hidden="true" class="sno-arrow-up fa fa-arrow-up"><span class="icon-hidden-text">Scroll to Top</span></div></a></div><div class="lf_headerleft"><a href="/"><img src="https://www.torchonline.com/wp-content/uploads/2017/10/Torch-logo-copy.png" alt="The Independent Student Newspaper of St. John&#039;s University" /></a></div><div class="hover_title"><div class="hover_titletext">PLUG Ticket Sweeps SGI Elections</div><span id="progress-bar"><span id="progress-bar-color"></span></span></div></div><div class="clear"></div></div><div id="hoverbar_menu"><ul id="slidemenu" class="mobile-menu"><li class="mobile-search"><form method="get" id="searchform-alt-left" action="https://www.torchonline.com/">
									<label for="s-alt-left" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" id="searchsubmit-left" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="mobile-menu"><ul id="menu-top-menu-2" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-2234331"><a href="https://www.torchonline.com">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-208"><a href="https://www.torchonline.com/about/">About</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234920"><a href="https://www.torchonline.com/about/">About</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-210"><a href="https://www.torchonline.com/about/staff/">Staff</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234919"><a href="https://www.torchonline.com/join/">Join</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2222954"><a href="https://www.torchonline.com/advertising/">Advertising</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234320"><a href="https://www.torchonline.com/job-board/">Job Board</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234335"><a href="https://www.torchonline.com/classifieds/">Classifieds</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2228097"><a href="https://www.torchonline.com/pdfissues/">Full Issues</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2228108"><a href="https://www.torchonline.com/subscriptions/">Subscribe</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2234251"><a href="https://www.torchonline.com/story-submission/">Story Submission</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234653"><a href="https://www.torchonline.com/story-submission/">Story Submission</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234652"><a href="https://www.torchonline.com/pitch-to-us/">Pitch to Us!</a></li>
</ul>
</li>
</ul></div></ul></div><script type="text/javascript">
		$(document).ready(function(){
			

			function sharingIconsResize() {
				if ($(window).width() < 850) {
					var socialwidth;
					var count = $("#mobile-socialmedia .sharing-mobile-show").length;
					if (count != 0) {
						socialwidth = 100 / count;
						$('#mobile-socialmedia .sharing-icon').width(socialwidth + '%');
					}
				} else {
					$('#sno_hoverbar .sharing-icon').width('50px');
				}
			}
						
			$('.sno-search-button').click(function() {
				$('#sno_hoversearch').fadeToggle();
				$('#sno_hoversearch').css({ top: '0' });
				$('#s-alt').focus();
			});
			$('.sno-search-close').click(function() {
				$('#sno_hoversearch').fadeToggle();
				$('#sno_hoversearch').css({ top: '-50px' });
			});

			var NavScrollTop		= $(window).scrollTop();
    		
    		if( $('.navbarwrap').length ) {
    			var	TopNavOffset 		= $('.navbarwrap').offset().top;
				var TopNavDistance		= (TopNavOffset - NavScrollTop);
   	 		}
   	 		if( $('.subnavbarwrap').length ) {
	   	 		var	BottomNavOffset 	= $('.subnavbarwrap').offset().top;
	   	 		var	BottomNavDistance	= (BottomNavOffset - NavScrollTop);
   	 		}
   	 		
   	 		$('#hoverbar_menu .mobile-menu').height( $(window).height() - 50);
   	 		
   	 		var HoverOffset = 0, HoverOffset2 = 0;
			   	 		var HoverHeight = $('#sno_hoverbar').outerHeight();
   	 		var HoverHeight2 = $('#sno_hoverbar').outerHeight();
   	 		
			
			var CurrentScroll = 0;
			var WindowHeight = $(document).height() - $('.footerwrap').height();
			
							WindowHeight -= $('#commentswrap').height();		
						
			
			$('.sno-menu').click(function() {
			
				$('#hoverbar_menu').fadeToggle();
				$('.menu-icon').toggle();
				$('.close-icon').toggle();
				$('#hoverbar_menu').css({ height: $(window).height() - 50 });
			
			});
			
			$(window).scroll(function(event) {
				var NextScroll = $(this).scrollTop();

				var ScrollPercent = (NextScroll / (WindowHeight - $(window).height())) * 100;
				

				$('#progress-bar-color').css({ width: ScrollPercent + '%'});
				$('#hoverbar_menu').css({ top: $('#sno_hoverbar').height() });
				
				if ( ScrollPercent > 100 ) {
										$('.sno-arrow-up').css({ background: '#ee2827', color: '#eee'});
					$('.sno-menu').css({ background: '#ee2827', color: '#eee'});
					$('.socialmedia .sharing-icon').css({ opacity: 1 })
					
					
				} else {
										$('.sno-arrow-up').css({ background: '#eee', color: '#ccc'});
					$('.sno-menu').css({ background: '#eee', color: '#ccc'});
				}
				var headerLocation = $("#wrap").offset().top;
				if (NextScroll > CurrentScroll && $(document).scrollTop() > headerLocation) {
					if ($('#sno_hoverbar').is(":hidden")) {
						$('#sno_hoverbar').show();
						$('#sno_hoverbar').stop().animate({ top: '0' }, { duration: 300, queue: false });
						
													if( $('.subnavbarwrap').length ) {	
								$('.subnavbarwrap').stop().animate({ top: HoverHeight2 +'px'}, { duration: 300, queue: false });
							}
												
													var lpb = $('.lf_headerleft').width();
														var rpb = 50 + $('.socialmedia').width();
															rpb += $('#sno_hoverbar .sno-search-button').width();
														$('#progress-bar').css({ left: lpb + 'px', right: rpb + 'px'})
						        			}


        			
				} else if (NextScroll < CurrentScroll && $(document).scrollTop() < ( headerLocation + 300 ) && $('#sno_hoverbar').is(":visible")) {
				
						$('#hoverbar_menu').hide();
						$('.close-icon').hide();
						$('.menu-icon').show();
						$('#hoverbar_menu').hide();
						$('#sno_hoverbar').stop().animate({
							top: '-50px'
							},300, function(){
								$('#sno_hoverbar').hide();
							});
						if ( $('.navbarwrap').length ) { $('.navbarwrap').stop().animate({ top: HoverOffset + 'px'},300); }
						if ( $('.subnavbarwrap').length ) { $('.subnavbarwrap').stop().animate({ top: HoverOffset2 + 'px'},300); }

				}
			CurrentScroll = NextScroll;
			});


		});

		$("#snotop").hide();
	
		$(function () {
			$(window).scroll(function () {
				if ($(this).scrollTop() > 500) {
					$('#snotop').fadeIn();
				} else {
					$('#snotop').fadeOut();
				}
			});

			$('#back-top a').click(function () {
				$('body,html').animate({
					scrollTop: 0
				}, 800);
				return false;
			});

		});
	</script></body></html>