<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"> 
<head>
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	<meta name="distribution" content="global" />
	<meta name="robots" content="follow, all" />
	<meta name="language" content="en, sv" />
	<meta name="viewport" content="width=device-width" />
		<link rel="Shortcut Icon" href="https://www.torchonline.com/wp-content/uploads/2020/04/torchfaviocon2.png" type="image/x-icon" />
	<link rel="alternate" type="application/rss+xml" title="The Torch RSS 2.0" href="https://www.torchonline.com/feed/" />
	<link rel="alternate" type="text/xml" title="The Torch RSS .92" href="https://www.torchonline.com/feed/rss/" />
	<link rel="alternate" type="application/atom+xml" title="The Torch Atom 0.3" href="https://www.torchonline.com/feed/atom/" />
	<title>At Its Halfway Point, “Moon Knight” Has Already Surpassed Expectations &#8211; The Torch</title>
<meta name='robots' content='max-image-preview:large' />
<link rel="alternate" type="application/rss+xml" title="The Torch &raquo; At Its Halfway Point, “Moon Knight” Has Already Surpassed Expectations Comments Feed" href="https://www.torchonline.com/culture/2022/04/19/at-its-halfway-point-moon-knight-has-already-surpassed-expectations/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.torchonline.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
			
	<link rel='stylesheet' id='dashicons-css'  href='https://www.torchonline.com/wp-includes/css/dashicons.min.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://www.torchonline.com/wp-includes/js/thickbox/thickbox.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='elusive-css'  href='https://www.torchonline.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/elusive.min.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.torchonline.com/wp-content/plugins/menu-icons/css/fontawesome/css/all.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='foundation-icons-css'  href='https://www.torchonline.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/foundation-icons.min.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='menu-icons-extra-css'  href='https://www.torchonline.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.12.11' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.torchonline.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.3' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='contact-form-7-css'  href='https://www.torchonline.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.5.6' type='text/css' media='all' />
<link rel='stylesheet' id='flytedesk-digital-css'  href='https://www.torchonline.com/wp-content/plugins/flytedesk-digital/public/css/flytedesk-digital-public.css?ver=20181101' type='text/css' media='all' />
<link rel='stylesheet' id='sno-infographics-widget-style-css'  href='https://www.torchonline.com/wp-content/plugins/sno-infographics/assets/style/sno-infographics-widget-style.css?ver=0.2.7' type='text/css' media='all' />
<link rel='stylesheet' id='sno-pdf-flipbook-plugin-style-css'  href='https://www.torchonline.com/wp-content/plugins/sno-pdf-flipbook/assets/style/docs.css?ver=1.0.6' type='text/css' media='all' />
<link rel='stylesheet' id='sno-pdf-flipbook-jquery-ui-style-css'  href='https://www.torchonline.com/wp-content/plugins/sno-pdf-flipbook/assets/style/jquery.ui.css?ver=1.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='sno-polls-widget-style-css'  href='https://www.torchonline.com/wp-content/plugins/sno-polls/assets/style/sno-polls-widget-style.css?ver=0.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://www.torchonline.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.6' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background: #d8e1eb;
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='wxacs_front_style-css'  href='https://www.torchonline.com/wp-content/plugins/scrollbar-by-webxapp/assets/css/style.css?ver=1.2.1' type='text/css' media='all' />
<style id='wxacs_front_style-inline-css' type='text/css'>
::-webkit-scrollbar {
                                width: 9px;
                         }::-webkit-scrollbar-thumb {
                            background: rgb(132, 132, 130) ;
                            border-radius:8px;
                            height:82px;
                            
                       }::-webkit-scrollbar-thumb:hover {
                            background: rgb(103, 103, 103); 
                             
                            }::-webkit-scrollbar-track {
                                background: rgba(132, 132, 130, 0); 
                           }
</style>
<link rel='stylesheet' id='sno-comments-css-css'  href='https://www.torchonline.com/wp-content/themes/snoflex/comments/comments.css?ver=20211015' type='text/css' media='all' />
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Lato%3A400%2C700%7COxygen%3A200%2C400%2C700%2C500%7COpen+Sans%3A400%2C700%7CRoboto%3A200%2C600%2C400%2C700%7CArimo%3A400%2C700&#038;display=swap&#038;ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='flex-parallax-css'  href='https://www.torchonline.com/wp-content/themes/snoflex/parallax/css/main.css?ver=20191203' type='text/css' media='all' />
<link rel='stylesheet' id='flex-flexslider-css'  href='https://www.torchonline.com/wp-content/themes/snoflex/tools/flexslider/flexslider.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-superfish-css'  href='https://www.torchonline.com/wp-content/themes/snoflex/tools/superfish/css/superfish.css?ver=20210512' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-css'  href='https://www.torchonline.com/wp-content/themes/snoflex/javascript/remodal.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-default-css'  href='https://www.torchonline.com/wp-content/themes/snoflex/javascript/remodal-default-theme.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-stylesheet-css'  href='https://www.torchonline.com/wp-content/themes/snoflex/style.css?ver=20220401' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-official-css'  href='https://use.fontawesome.com/releases/v5.15.2/css/all.css' type='text/css' media='all' integrity="sha384-vSIIfh2YWi9wW0r9iZe7RJPrKwp6bG+s9QZMoITbCckVJqGCCRhc+ccxNcdpHuYu" crossorigin="anonymous" />
<link rel='stylesheet' id='font-awesome-official-v4shim-css'  href='https://use.fontawesome.com/releases/v5.15.2/css/v4-shims.css' type='text/css' media='all' integrity="sha384-1CjXmylX8++C7CVZORGA9EwcbYDfZV2D4Kl1pTm3hp2I/usHDafIrgBJNuRTDQ4f" crossorigin="anonymous" />
<style id='font-awesome-official-v4shim-inline-css' type='text/css'>
@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.eot"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.svg#fontawesome") format("svg");
}

@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.eot"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.svg#fontawesome") format("svg");
}

@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.eot"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.svg#fontawesome") format("svg");
unicode-range: U+F004-F005,U+F007,U+F017,U+F022,U+F024,U+F02E,U+F03E,U+F044,U+F057-F059,U+F06E,U+F070,U+F075,U+F07B-F07C,U+F080,U+F086,U+F089,U+F094,U+F09D,U+F0A0,U+F0A4-F0A7,U+F0C5,U+F0C7-F0C8,U+F0E0,U+F0EB,U+F0F3,U+F0F8,U+F0FE,U+F111,U+F118-F11A,U+F11C,U+F133,U+F144,U+F146,U+F14A,U+F14D-F14E,U+F150-F152,U+F15B-F15C,U+F164-F165,U+F185-F186,U+F191-F192,U+F1AD,U+F1C1-F1C9,U+F1CD,U+F1D8,U+F1E3,U+F1EA,U+F1F6,U+F1F9,U+F20A,U+F247-F249,U+F24D,U+F254-F25B,U+F25D,U+F267,U+F271-F274,U+F279,U+F28B,U+F28D,U+F2B5-F2B6,U+F2B9,U+F2BB,U+F2BD,U+F2C1-F2C2,U+F2D0,U+F2D2,U+F2DC,U+F2ED,U+F328,U+F358-F35B,U+F3A5,U+F3D1,U+F410,U+F4AD;
}
</style>
<link rel='stylesheet' id='wp-paginate-css'  href='https://www.torchonline.com/wp-content/plugins/wp-paginate/css/wp-paginate.css?ver=2.1.8' type='text/css' media='screen' />
<script type='text/javascript' src='https://www.torchonline.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' id='flytedesk-digital-js-extra'>
/* <![CDATA[ */
var flytedesk_digital_publisher = {"uuid":"8b8311a3-abfb-4b1c-8cfe-1cca74dfae43"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/plugins/flytedesk-digital/public/js/flytedesk-digital-public.js?ver=20181101' id='flytedesk-digital-js'></script>
<script type='text/javascript' id='sno-comments-js-js-extra'>
/* <![CDATA[ */
var comment_ajax_object = {"ajaxurl":"https:\/\/www.torchonline.com\/wp-admin\/admin-ajax.php","nonce":"a1a4ad574c","jason":"wallestad"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/comments/comments.js?ver=20211013' id='sno-comments-js-js'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/tools/flexslider/jquery.flexslider.js?ver=5.9.3' id='flex-flexslider-script-js'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/javascript/jquery-visible.js?ver=5.9.3' id='flex-jquery-visible-js'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/tools/superfish/js/hoverintent.js?ver=20210512' id='flex-hoverintent-js'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/tools/superfish/js/superfish.js?ver=20210513' id='flex-superfish-js'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/tools/superfish/js/supersubs.js?ver=20210513' id='flex-supersubs-js'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/javascript/jquery-scrolltofixed-min.js?ver=5.9.3' id='flex-scrollfix-js'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/javascript/remodal.min.js?ver=5.9.3' id='flex-remodal-js'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/javascript/jquery.cycle.all.min.js?ver=5.9.3' id='flex-cycle-js'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/javascript/jcarousellite_1.0.1c4.js?ver=5.9.3' id='flex-bnticker-js'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/javascript/menus-init.js?ver=20210513' id='flex-menus-js'></script>
<script type='text/javascript' id='flex-theme-js-js-extra'>
/* <![CDATA[ */
var frontend_ajax_object = {"ajaxurl":"https:\/\/www.torchonline.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/javascript/sno-theme.js?ver=20220102' id='flex-theme-js-js'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/themes/snoflex/parallax/js/skrollr.js?ver=5.9.3' id='flex-parallax-js'></script>
<link rel="https://api.w.org/" href="https://www.torchonline.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.torchonline.com/wp-json/wp/v2/posts/2242822" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.torchonline.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.torchonline.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.9.3" />
<link rel="canonical" href="https://www.torchonline.com/culture/2022/04/19/at-its-halfway-point-moon-knight-has-already-surpassed-expectations/" />
<link rel='shortlink' href='https://www.torchonline.com/?p=2242822' />
<link rel="alternate" type="application/json+oembed" href="https://www.torchonline.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.torchonline.com%2Fculture%2F2022%2F04%2F19%2Fat-its-halfway-point-moon-knight-has-already-surpassed-expectations%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.torchonline.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.torchonline.com%2Fculture%2F2022%2F04%2F19%2Fat-its-halfway-point-moon-knight-has-already-surpassed-expectations%2F&#038;format=xml" />


<!-- Start of Open Graph Meta Tags -->

<meta property="og:title" content="At Its Halfway Point, “Moon Knight” Has Already Surpassed Expectations" />
<meta property="og:type" content="article" />
<meta name="author" content="Connor Richards" />
<meta property="og:url" content="https://www.torchonline.com/culture/2022/04/19/at-its-halfway-point-moon-knight-has-already-surpassed-expectations/" />
<meta property="og:image" content="https://www.torchonline.com/wp-content/uploads/2022/04/unnamed-5-5.png" />
	<meta property="og:image:width" content="512" />
	<meta property="og:image:height" content="237" />
	<meta property="og:site_name" content="The Torch" />
	<meta property="og:description" content="Marvel’s latest Disney+ show, “Moon Knight,” recently reached its halfway point and fans cannot get enough of the latest addition to the MCU." />
	<meta name="description" content="Marvel’s latest Disney+ show, “Moon Knight,” recently reached its halfway point and fans cannot get enough of the latest addition to the MCU." />
	<meta property="article:section" content="Culture" />
	<meta property="article:tag" content="Marvel,Moon Knight" />
<!-- End of Open Graph Meta Tags -->

		<script>
	jQuery(document).ready(function() {
		var wpadminbar = jQuery('#wpadminbar').outerHeight();
		if (wpadminbar == null) { var wpadminbar = 0; }
		if (jQuery('#wpadminbar').is(":hidden")) { wpadminbar = 0; }

	
				jQuery('.subnavbarwrap').scrollToFixed({
			marginTop:  wpadminbar,
		});		
		
		
			var menuTop;
		if (jQuery('#subnavbar').length){
			var menuTop = jQuery('#subnavbar').offset().top;
		}
		menuTop -= wpadminbar;
		jQuery(window).scroll(function () {
			if (jQuery(this).scrollTop() > menuTop) {
				jQuery('#subnavbar .mini-logo').hide();
				jQuery('#show-mini-logo-bottom').fadeIn();
				if ( jQuery.isFunction(jQuery.fn.resizeMenuBottom)) resizeMenuBottom();
				
			} else {
				jQuery('#show-mini-logo-bottom').hide();
				jQuery('#subnavbar .mini-logo').fadeIn();
			}
		});
		
	
	});
</script>
<style type="text/css" media="screen">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</style></head>

<body data-rsssl=1 class="sno-animate-active"><div class='navbarwrap'
						data-align='left' 
						data-margin='0' 
						data-style='Bar' 
						data-minilogo='false' 
						data-mode='default' 
						data-height='30px' 
						data-width='1290'><div class="navbarcontainer"><div id="navbar" class="sno-classic-menuwrap"><div id="navbarbackground"><div id="menu-a-menu"><nav aria-label="Secondary Menu"><div class="menu-top-menu-container"><ul id="menu-top-menu" class="sf-menu sno-top-menu"><li id="menu-item-2234331" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-2234331"><a href="https://www.torchonline.com">Home</a></li>
<li id="menu-item-208" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-208"><a href="https://www.torchonline.com/about/">About</a>
<ul class="sub-menu">
	<li id="menu-item-210" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-210"><a href="https://www.torchonline.com/about/staff/">Editorial Board</a></li>
	<li id="menu-item-2234919" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234919"><a href="https://www.torchonline.com/join/">Join</a></li>
	<li id="menu-item-2238698" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2238698"><a href="https://www.torchonline.com/about/staff-2/">Staff</a></li>
</ul>
</li>
<li id="menu-item-2222954" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2222954"><a href="https://www.torchonline.com/advertising/">Advertising</a></li>
<li id="menu-item-2234320" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234320"><a href="https://www.torchonline.com/job-board/">Job Board</a></li>
<li id="menu-item-2234335" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234335"><a href="https://www.torchonline.com/classifieds/">Classifieds</a></li>
<li id="menu-item-2238598" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2238598"><a href="/">Partner Links</a>
<ul class="sub-menu">
	<li id="menu-item-2238599" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2238599"><a href="https://www.yourlawyer.com/new-york/">New York Personal Injury Firm</a></li>
</ul>
</li>
<li id="menu-item-2228097" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2228097"><a href="https://www.torchonline.com/pdfissues/">Full Issues</a></li>
<li id="menu-item-2234251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2234251"><a href="https://www.torchonline.com/story-submission/">Story Submission</a>
<ul class="sub-menu">
	<li id="menu-item-2234653" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234653"><a href="https://www.torchonline.com/story-submission/">Story Submission</a></li>
	<li id="menu-item-2234652" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2234652"><a href="https://www.torchonline.com/pitch-to-us/">Pitch to Us!</a></li>
</ul>
</li>
<li id="menu-item-2241587" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2241587"><a href="https://www.torchonline.com/donate/">Donate</a>
<ul class="sub-menu">
	<li id="menu-item-2241584" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2241584"><a href="https://donorbox.org/the-torch">Donate</a></li>
	<li id="menu-item-2241588" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2241588"><a href="http://thetorch.redbubble.com/">Visit the Torch Shop</a></li>
</ul>
</li>
</ul></div><ul class='sno-menu-more sf-arrows' style='display:none'><li class='menu-more-item-top'><a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"></span></a><ul class="sno-hac-menu-more"</ul></li></ul></nav></div></div></div></div></div><div class="clear"></div><div id="sno_mobile_menu"><ul class="slidemenu mobile-menu"><li class="mobile-search-side"><div class="sno-side-menu side-close-icon"><i class="fas fa-times"></i><span class="icon-hidden-text">Close Menu</span></div><form method="get" class="searchform-alt-left" action="https://www.torchonline.com/">
									<label for="s-alt-left" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="mobile-menu"><ul id="menu-bottom-menu" class="menu"><li id="menu-item-211" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-211"><a href="https://www.torchonline.com/category/news/">News</a></li>
<li id="menu-item-2229873" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2229873"><a href="https://www.torchonline.com/category/sports/">Sports</a></li>
<li id="menu-item-213" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-213"><a href="https://www.torchonline.com/category/features/">Features</a></li>
<li id="menu-item-2229874" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2229874"><a href="https://www.torchonline.com/category/culture/">Culture</a></li>
<li id="menu-item-212" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-212"><a href="https://www.torchonline.com/category/opinion/">Opinion</a></li>
<li id="menu-item-2240753" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2240753"><a href="https://mailchi.mp/1ee43caabca4/torchnewsletter">Torch Newsletter</a></li>
<li id="menu-item-2241137" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2241137"><a href="https://us4.campaign-archive.com/?u=587ed2c2543665372998dc9d7&#038;id=6f6e88ffe5">Courtside Magazine 2021-2022</a></li>
<li id="menu-item-2239787" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2239787"><a href="https://www.torchonline.com/category/coronavirus-st-johns/">coronavirus st. john&#8217;s</a></li>
</ul></div></ul></div><div id="wrap" class="bodywrap"><div id="mobile-menu"><div class="sitetitle"><div class="headerlink headersmall" style="display:none"><img src="https://www.torchonline.com/wp-content/uploads/2020/10/new-torch-logo-2020-whitebg.png" class="headerimage" alt="The Independent Student Newspaper of St. John&#039;s University" /></div><div class="headerlink headermedium" style="display:none"><img src="https://www.torchonline.com/wp-content/uploads/2020/10/new-torch-logo-2020-whitebg.png" class="headerimage" alt="The Independent Student Newspaper of St. John&#039;s University" /></div><div class="headerlink headerlarge"><img src="https://www.torchonline.com/wp-content/uploads/2020/10/new-torch-logo-2020-whitebg.png" class="headerlink headerimage" alt="The Independent Student Newspaper of St. John&#039;s University" /></div><h1 style="display:none" aria-hidden="true">The Torch</h1><script type="text/javascript">
						jQuery(document).ready(function(){
							jQuery(".headerlink").click(function(){
								window.location="https://www.torchonline.com";

							});
						});
					</script><div id="hover-menu-side"><div class="sno-menu-side menu-icon"><i class="fas fa-bars"></i><span class="icon-hidden-text">Menu</span></div></div></div><div class="clear"></div></div><div class="headerwrap"><div id="header" style="position:relative;"><div class="headerlarge"><a href="https://www.torchonline.com"><img src="https://www.torchonline.com/wp-content/uploads/2020/10/new-torch-logo-2020-whitebg.png" class="headerimage" alt="The Independent Student Newspaper of St. John&#039;s University" /></a></div><h1 style="display:none">The Torch</h1><div class="header-icons classic-icon"><style>.topnavbarleft { padding: 0px; width:auto; }</style>    
        								   	    										
    
        				
   	    
    
    		<a target="_blank" href="https://www.youtube.com/channel/UC27raD8kuNmoCAfG6Q3I3uw">
    		<div class="sno-icon social-border sno-youtube">
        		<i class="fa fa-youtube-play"></i>
        		<span class="icon-hidden-text">YouTube</span>
        	</div>
    	</a>
    
        				
        				    					
        				
						
	    				
    
	
	    
	
	    	<a target="_blank" href="https://www.instagram.com/sju_torch/">
    		<div class="sno-icon social-border sno-instagram">
        		<i class="fa fa-instagram"></i>
        		<span class="icon-hidden-text">Instagram</span>
        	</div>
    	</a>
	    				
    		<a target="_blank" href="https://twitter.com/sjutorch">
    		<div class="sno-icon social-border sno-twitter">
        		<i class="fa fa-twitter"></i>
        		<span class="icon-hidden-text">Twitter</span>
        	</div>
    	</a>
        				
	    	<a target="_blank" href="https://www.facebook.com/STJTorch/">
    		<div class="sno-icon social-border sno-facebook">
        		<i class="fa fa-facebook-f"></i>
        		<span class="icon-hidden-text">Facebook</span>
        	</div>
    	</a>
   
   <div class="social-spacer"></div>
   
   </div><div class="header-search">	<form method="get" id="searchform5766" action="https://www.torchonline.com/">
			<div class="search-button-container" id="searchthis5766">
			<button type="submit" disabled="disabled" id="sno-search-navbar-5766" class="sno-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
			<label for="s5766" class="assistive-text">Search</label>
			<input type="text" class="field s" name="s" id="s5766" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit5766" style="display:none;" value="Search" />
		</form>
	</div></div></div><div class="bottom-menu"><div class='subnavbarwrap sno-sticky'
						data-align='center' 
						data-margin='5' 
						data-style='Bar' 
						data-minilogo='false' 
						data-mode='default' 
						data-height='30px' 
						data-width='1290'><div class="subnavbarcontainer"><div id="subnavbar" class="sno-classic-menuwrap"><div id="subnavbarbackground"><div id="menu-b-menu"><nav aria-label="Main Menu"><div class="menu-bottom-menu-container"><ul id="menu-bottom-menu-1" class="sf-menu sno-bottom-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-211"><a href="https://www.torchonline.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2229873"><a href="https://www.torchonline.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-213"><a href="https://www.torchonline.com/category/features/">Features</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2229874"><a href="https://www.torchonline.com/category/culture/">Culture</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-212"><a href="https://www.torchonline.com/category/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2240753"><a href="https://mailchi.mp/1ee43caabca4/torchnewsletter">Torch Newsletter</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2241137"><a href="https://us4.campaign-archive.com/?u=587ed2c2543665372998dc9d7&#038;id=6f6e88ffe5">Courtside Magazine 2021-2022</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2239787"><a href="https://www.torchonline.com/category/coronavirus-st-johns/">coronavirus st. john&#8217;s</a></li>
</ul></div><ul class='sno-menu-more sf-arrows' style='display:none'><li class='menu-more-item-top'><a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"></span></a><ul class="sno-hac-menu-more"</ul></li></ul></nav></div></div><div class="clear"></div></div></div></div></div><div class="clear"></div><div id="fullwrap" style="position:relative;"><div class="innerbackgroundwrap "><div class="innerbackground"><div id='snopostid-2242822' class='snopostid'><div id='storypage' class='full-width sno-story-2242822'><div id="content"><div id='contentleft'><div class="postarea"><div role="main"><h1 id="storyheadline" class="storyheadline">At Its Halfway Point, “Moon Knight” Has Already Surpassed Expectations</h1><div class="storydeckbottom"></div><div class="storydeck"><p>Marvel Studios’ latest project is different, but in a good way</p></div><div id="storymeta" class="storymeta"><p> <a href="https://www.torchonline.com/staff_name/connor-richards/" class="creditline">Connor Richards</a>, Staff Writer<span class="storydate"><span class="byline-divider">|</span><span class="time-wrapper">April 19, 2022</span></span></p></div><span class="storycontent"><figure id="attachment_2242823" aria-describedby="caption-attachment-2242823" style="width: 512px" class="wp-caption aligncenter"><a href="https://www.torchonline.com/wp-content/uploads/2022/04/unnamed-5-5.png"><img class="wp-image-2242823 size-full" src="https://www.torchonline.com/wp-content/uploads/2022/04/unnamed-5-5.png" alt="" width="512" height="237" srcset="https://www.torchonline.com/wp-content/uploads/2022/04/unnamed-5-5.png 512w, https://www.torchonline.com/wp-content/uploads/2022/04/unnamed-5-5-475x220.png 475w, https://www.torchonline.com/wp-content/uploads/2022/04/unnamed-5-5-300x139.png 300w" sizes="(max-width: 512px) 100vw, 512px" /></a><figcaption id="caption-attachment-2242823" class="wp-caption-text">Photo Courtesy / <a href="https://www.youtube.com/watch?v=ZtxO9NQHGiY" target="_blank" rel="noopener">YouTube Marvel Entertainment</a></figcaption></figure>
<p><span style="font-weight: 400;">The Marvel Cinematic Universe is dominated by what seem like household names at this point, so it can be easy to forget that many characters were relatively unknown to the general public at one time. For example, heroes like Iron Man and Doctor Strange did not carry the same familiarity as Captain America or Spider-Man.</span></p>
<p><span style="font-weight: 400;">Kevin Feige and the rest of Marvel’s leadership team are hoping to replicate their previous successes in introducing Moon Knight through a six episode television series.</span></p>
<p><span style="font-weight: 400;">The latest series from Marvel Studios to hit Disney+, “Moon Knight” stars Oscar Isaac in the titular role. While most superheroes have a real name hidden behind their alias, Isaac’s character is unique in that he has two — a result of his dissociative identity disorder. While the American Marc Spector is a former secret agent turned mercenary, Steven Grant comes equipped with a British accent and a plethora of knowledge on ancient Egypt, stemming from his work in a museum gift shop. </span></p>
<p><span style="font-weight: 400;">Sharing the same body, there is a constant struggle between the two identities for control. This is only further complicated when serving the Egyptian god Khonshu, who grants them an ancient armor transforming them into Moon Knight. Much of the deity’s bidding includes violence, something that Grant is much less comfortable with than Spector. Meanwhile, when it has come to utilizing technical skills and expertise, Grant has been the better option. </span></p>
<p><span style="font-weight: 400;">Even as the rivaling personas do not get along, their tag team dynamic — mixed with the power of the Moon Knight mantle — proved to be a winning combination throughout the first half of this series. </span></p>
<p><span style="font-weight: 400;">Isaac has taken on this role and executed it to perfection thus far. He conveys a torment in each of the identities his character holds, stemming from not only the anguish of lacking full control, but the heavy burden of serving Khonshu as well. Spector also hopes to protect his wife Layla, something that has clearly taken a toll on him. Though Grant does not have that same weight of responsibility upon him, this is a high stress environment that he has been abruptly thrown into. </span></p>
<p><span style="font-weight: 400;">With all of this in mind, Isaac has done a masterful job portraying these struggles. His talents are best displayed at the end of the second episode, but his overall performance is something that I hope he receives critical acclaim for when the series is said and done.</span></p>
<p><span style="font-weight: 400;">Though Spector and Grant are typically at odds with one another, it is clear that they will need to work together if they want to defeat Ethan Hawke’s Arthur Harrow, the villain of the series. Hawke has played this role to perfection, as he is a manipulative, cultic zealot committed to unleashing the Egyptian goddess Ammit. One flaw I see in this role is its similarities to the villains in “Captain America: The Winter Soldier,” though this approach is mythical rather than technological. Even with feelings of déjà vu relating back to the 2014 masterpiece, I think the villain in “Moon Knight” is very well-developed.</span></p>
<p><span style="font-weight: 400;">Beyond the plot and writing so far, the technical aspects of the series have been sensational. The set designs have been aesthetically pleasing throughout, but most notably in the third episode. While the action scenes have left something to be desired, the storytelling and purpose behind them have made up for those issues. If this were a theatrical release, it would receive heavy criticism for that aspect; however, this is where Marvel’s expansion into producing limited series benefits them greatly.</span></p>
<p><span style="font-weight: 400;">On a separate note, there is a mysterious aspect to “Moon Knight” that sets it apart from other Marvel projects. Sure, there are twists and turns in any series, but lead writer, Jeremy Slater, does not spell out every detail for the viewer in this one. I enjoy that because many of the main characters are also unsure of what is going on. This facet has made me all the more engaged with the show on a week to week basis, which amplifies the “Marvel experience” so many can relate to when consuming all of the studio’s work.</span></p>
<p><span style="font-weight: 400;">While there are still three episodes to go, I’ve enjoyed much of what “Moon Knight” has had to offer so far. It is fantastic to see so much representation in a large-scale project, whether that be their inclusion of a character with dissociative identity disorder or the central role of Egypt and its rich culture. Expanding diversity within the Marvel Cinematic Universe, with the platform this franchise has, can do wonderful things for people with real-world connections to these aspects of the show.</span><span style="font-weight: 400;">“Moon Knight” is now streaming on Disney+, with new episodes releasing every Wednesday until its May 4 finale. Disney+ is also home to most of</span><a href="https://www.torchonline.com/tag/marvel/"><span style="font-weight: 400;"> the Marvel Studios catalog of films,</span></a><span style="font-weight: 400;"> though you do not need to be a comic book expert to enjoy this limited series.</span></p>
</span></div><div class="clear"></div><ul class="snotags"><li class="blockstag"><a href="https://www.torchonline.com/tag/marvel/" rel="tag">Marvel</a></li><li class="blockstag"><a href="https://www.torchonline.com/tag/moon-knight/" rel="tag">Moon Knight</a></li></ul>    	<div class="clear"></div>
		<div class="sno-comment-bar">
			Leave a Comment		</div>
		</div><div class="clear"></div></div></div></div></div><div class="sno_teaserbar" id="sno_teaserbar"><div class="stb_nav"><div class="custom-navigation"><span class="flex-prev"><div class="stb_left"><div class="fa fa-angle-left"><div class="icon-hidden-text">Navigate Left</div></div></div></span></div></div><div id='stb-container' class='flexslider'><ul class="slides"><li class='stb-top-row'><div class='stb_image'><a href='https://www.torchonline.com/culture/2022/04/20/curated-collections-the-i-dos-and-i-donts-of-wedding-movies/#photo'><img src='https://www.torchonline.com/wp-content/uploads/2022/04/unnamed-6-2-475x277.png' id='grow-stb2242829'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Photo Courtesy / YouTube Bride Wars'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb2242829').mouseenter(function() {
   											jQuery('#grow-stb2242829').removeClass('shrink');
   											jQuery('#grow-stb2242829').removeClass('grow');
   											jQuery('#grow-stb2242829').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb2242829').addClass('shrink');
   										});});</script><p class='stb-cat'>Culture</p><p class="relatedtitle"><a href="https://www.torchonline.com/culture/2022/04/20/curated-collections-the-i-dos-and-i-donts-of-wedding-movies/">Curated Collections: &#8216;The I Do’s&#8217; and &#8216;I Don&#8217;t&#8217;s&#8217; of Wedding Movies</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.torchonline.com/culture/2022/04/18/the-story-of-barlow-bear-and-the-birth-of-grammy-winning-musical-bridgerton-the-unofficial-musical/#photo'><img src='https://www.torchonline.com/wp-content/uploads/2022/04/unnamed-5-4-475x285.png' id='grow-stb2242809'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Photo Courtesy / YouTube Barlow and Bear'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb2242809').mouseenter(function() {
   											jQuery('#grow-stb2242809').removeClass('shrink');
   											jQuery('#grow-stb2242809').removeClass('grow');
   											jQuery('#grow-stb2242809').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb2242809').addClass('shrink');
   										});});</script><p class='stb-cat'>Culture</p><p class="relatedtitle"><a href="https://www.torchonline.com/culture/2022/04/18/the-story-of-barlow-bear-and-the-birth-of-grammy-winning-musical-bridgerton-the-unofficial-musical/">The Story of Barlow &#038; Bear and the Birth of Grammy Winning Musical “Bridgerton: The Unofficial Musical”</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.torchonline.com/culture/2022/04/11/bridgerton-season-two/#photo'><img src='https://www.torchonline.com/wp-content/uploads/2022/04/unnamed-copy-2-475x240.jpg' id='grow-stb2242785'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='PHOTO COURTESY / Youtube Netflix'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb2242785').mouseenter(function() {
   											jQuery('#grow-stb2242785').removeClass('shrink');
   											jQuery('#grow-stb2242785').removeClass('grow');
   											jQuery('#grow-stb2242785').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb2242785').addClass('shrink');
   										});});</script><p class='stb-cat'>Culture</p><p class="relatedtitle"><a href="https://www.torchonline.com/culture/2022/04/11/bridgerton-season-two/">Bridgerton Season 2: A Diamond of the First Water</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.torchonline.com/culture/2022/04/11/netflixs-the-bubble-is-a-comically-bad-movie/#photo'><img src='https://www.torchonline.com/wp-content/uploads/2022/04/unnamed-6-475x194.jpg' id='grow-stb2242774'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Photo Courtesy / YouTube Netflix'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb2242774').mouseenter(function() {
   											jQuery('#grow-stb2242774').removeClass('shrink');
   											jQuery('#grow-stb2242774').removeClass('grow');
   											jQuery('#grow-stb2242774').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb2242774').addClass('shrink');
   										});});</script><p class='stb-cat'>Culture</p><p class="relatedtitle"><a href="https://www.torchonline.com/culture/2022/04/11/netflixs-the-bubble-is-a-comically-bad-movie/">Netflix&#8217;s &#8220;The Bubble&#8221; Is A Comically-Bad Movie</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.torchonline.com/culture/2022/04/11/the-academy-bans-will-smith-from-the-oscars-for-10-years/#photo'><img src='https://www.torchonline.com/wp-content/uploads/2022/04/unnamed-5-2-475x294.png' id='grow-stb2242771'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Smith holds the Academy Award trophy for his first Oscar'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb2242771').mouseenter(function() {
   											jQuery('#grow-stb2242771').removeClass('shrink');
   											jQuery('#grow-stb2242771').removeClass('grow');
   											jQuery('#grow-stb2242771').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb2242771').addClass('shrink');
   										});});</script><p class='stb-cat'>Culture</p><p class="relatedtitle"><a href="https://www.torchonline.com/culture/2022/04/11/the-academy-bans-will-smith-from-the-oscars-for-10-years/">The Academy Bans Will Smith From The Oscars For 10 Years</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.torchonline.com/culture/2022/04/08/notable-novels-normal-people-by-sally-rooney/#photo'><img src='https://www.torchonline.com/wp-content/uploads/2022/04/unnamed-4-475x316.jpg' id='grow-stb2242757'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Sally Rooneys novel.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb2242757').mouseenter(function() {
   											jQuery('#grow-stb2242757').removeClass('shrink');
   											jQuery('#grow-stb2242757').removeClass('grow');
   											jQuery('#grow-stb2242757').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb2242757').addClass('shrink');
   										});});</script><p class='stb-cat'>Culture</p><p class="relatedtitle"><a href="https://www.torchonline.com/culture/2022/04/08/notable-novels-normal-people-by-sally-rooney/">Notable Novels: “Normal People” by Sally Rooney</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.torchonline.com/culture/2022/04/07/welcome-to-harrys-house/#photo'><img src='https://www.torchonline.com/wp-content/uploads/2022/04/Screen-Shot-2022-04-07-at-6.33.31-PM-475x286.png' id='grow-stb2242749'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Harrys House lead single music video.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb2242749').mouseenter(function() {
   											jQuery('#grow-stb2242749').removeClass('shrink');
   											jQuery('#grow-stb2242749').removeClass('grow');
   											jQuery('#grow-stb2242749').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb2242749').addClass('shrink');
   										});});</script><p class='stb-cat'>Culture</p><p class="relatedtitle"><a href="https://www.torchonline.com/culture/2022/04/07/welcome-to-harrys-house/">Welcome To Harry&#8217;s House</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.torchonline.com/culture/2022/04/07/yo-soy-puertorriquena-ariana-debose-makes-history-at-oscars/#photo'><img src='https://www.torchonline.com/wp-content/uploads/2022/04/unnamed-1-475x250.jpg' id='grow-stb2242746'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Ariana DeBose accepts Academy Award for West Side Story.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb2242746').mouseenter(function() {
   											jQuery('#grow-stb2242746').removeClass('shrink');
   											jQuery('#grow-stb2242746').removeClass('grow');
   											jQuery('#grow-stb2242746').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb2242746').addClass('shrink');
   										});});</script><p class='stb-cat'>Culture</p><p class="relatedtitle"><a href="https://www.torchonline.com/culture/2022/04/07/yo-soy-puertorriquena-ariana-debose-makes-history-at-oscars/">¡Yo soy Puertorriqueña!:” Ariana DeBose Makes History At Oscars</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.torchonline.com/culture/2022/04/07/human-resources-big-mouths-raunchier-sister/#photo'><img src='https://www.torchonline.com/wp-content/uploads/2022/04/unnamed-475x271.jpg' id='grow-stb2242741'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Human Resources sign, animated comedy.'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb2242741').mouseenter(function() {
   											jQuery('#grow-stb2242741').removeClass('shrink');
   											jQuery('#grow-stb2242741').removeClass('grow');
   											jQuery('#grow-stb2242741').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb2242741').addClass('shrink');
   										});});</script><p class='stb-cat'>Culture</p><p class="relatedtitle"><a href="https://www.torchonline.com/culture/2022/04/07/human-resources-big-mouths-raunchier-sister/">“Human Resources:” “Big Mouth’s” Raunchier Sister</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.torchonline.com/culture/2022/04/04/i-love-lucy-was-never-just-a-title/#photo'><img src='https://www.torchonline.com/wp-content/uploads/2022/04/unnamed-121-475x270.png' id='grow-stb2242732'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='“‘I Love Lucy’ Was Never Just A Title”'/></a></div><script type='text/javascript'>
									jQuery(document).ready(function() {
   								 		jQuery('#grow-stb2242732').mouseenter(function() {
   											jQuery('#grow-stb2242732').removeClass('shrink');
   											jQuery('#grow-stb2242732').removeClass('grow');
   											jQuery('#grow-stb2242732').addClass('grow');
   										}).mouseleave(function() {
   											jQuery('#grow-stb2242732').addClass('shrink');
   										});});</script><p class='stb-cat'>Culture</p><p class="relatedtitle"><a href="https://www.torchonline.com/culture/2022/04/04/i-love-lucy-was-never-just-a-title/">“‘I Love Lucy’ Was Never Just A Title”</a></p></li></ul></div><div class="stb_nav"><div class="custom-navigation"><span class="flex-next"><div class="stb_right"><div class="fa fa-angle-right"><div class="icon-hidden-text">Navigate Right</div></div></div></span></div></div></div><div class="clear"></div><script type="text/javascript" charset="utf-8">
		jQuery(document).ready(function() {
			jQuery('#stb-container').flexslider({
				animation: "slide",
				animationLoop: true,
				customDirectionNav: jQuery(".stb_nav .custom-navigation span"), 
       			slideshow: false,
				itemMargin: 2,
				touch: true,
				itemWidth: 300,
				minItems: 1,
				move: 1,
				maxItems: 5
  			});

		});

			jQuery(document).ready(function(){
			
			var TB_CurrentScroll = 0; var TB_NextScroll = 0; var hbheight = 0;
			
			
			jQuery(window).scroll(function(event) {
				TB_CurrentScroll = TB_NextScroll;
				if (jQuery('#sno_hoverbar').is(":visible")) { hbheight = 50 }
				TB_NextScroll = jQuery(this).scrollTop();
				if (TB_NextScroll < TB_CurrentScroll && jQuery(document).scrollTop() > 500) {  // scrolling up on the page causes it to display
					if (jQuery('.sno_teaserbar').is(":hidden")) {
						jQuery('.sno_teaserbar').show();
						jQuery('.sno_teaserbar').stop().animate({ top: hbheight }, { duration: 300, queue: false });
					}
				}
				 else if ((TB_NextScroll > TB_CurrentScroll && jQuery(document).scrollTop() > 500) || jQuery(document).scrollTop() < 400 ){ // scrolling down on the page causes it to hide
					jQuery('.sno_teaserbar').stop().animate({
						top: '-86px'
						},200, function(){
							jQuery('.sno_teaserbar').hide();
						});
				} 
			});
				});
	</script></div></div></div><div style="clear:both;"></div><div class="footerwrap footer_single"><div id="footer"><div class="footername"><div class="footerright footer-icon"><style>.topnavbarleft { padding: 0px; width:auto; }</style>    
        								   	    										
    
        				
   	    
    
    		<a target="_blank" href="https://www.youtube.com/channel/UC27raD8kuNmoCAfG6Q3I3uw">
    		<div class="sno-icon social-border sno-youtube">
        		<i class="fa fa-youtube-play"></i>
        		<span class="icon-hidden-text">YouTube</span>
        	</div>
    	</a>
    
        				
        				    					
        				
						
	    				
    
	
	    
	
	    	<a target="_blank" href="https://www.instagram.com/sju_torch/">
    		<div class="sno-icon social-border sno-instagram">
        		<i class="fa fa-instagram"></i>
        		<span class="icon-hidden-text">Instagram</span>
        	</div>
    	</a>
	    				
    		<a target="_blank" href="https://twitter.com/sjutorch">
    		<div class="sno-icon social-border sno-twitter">
        		<i class="fa fa-twitter"></i>
        		<span class="icon-hidden-text">Twitter</span>
        	</div>
    	</a>
        				
	    	<a target="_blank" href="https://www.facebook.com/STJTorch/">
    		<div class="sno-icon social-border sno-facebook">
        		<i class="fa fa-facebook-f"></i>
        		<span class="icon-hidden-text">Facebook</span>
        	</div>
    	</a>
   
   <div class="social-spacer"></div>
   
   </div></div><div class="footersearch">	<form method="get" id="searchform1006" action="https://www.torchonline.com/">
			<div class="search-button-container" id="searchthis1006">
			<button type="submit" disabled="disabled" id="sno-search-navbar-1006" class="sno-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
			<label for="s1006" class="assistive-text">Search</label>
			<input type="text" class="field s" name="s" id="s1006" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
			<input type="submit" class="submit" name="submit" id="searchsubmit1006" style="display:none;" value="Search" />
		</form>
	</div><div class="clear"></div><div class="clear"></div><div class="footercredit"><div class="sno-footer-credit-inner">&copy; 2022 The Torch, all rights reserved. &bull; <a target='_blank' href='https://www.torchonline.com/disclosures/'>Privacy Policy</a> &bull; <a target='_blank' href='https://snoads.com/site/762'>Advertise</a> &bull;  <a href='https://snosites.com/why-sno/'>FLEX WordPress Theme</a> by <a href='http://snosites.com'>SNO</a> &bull; <a href="https://www.torchonline.com/wp-login.php">Log in</a></div></div><div class="clear"></div></div></div><script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-22842225-9', 'auto');
			ga('require', 'displayfeatures');
			ga('send', 'pageview');
		</script> 	
				<div class="sno-side-icons icon-inverse icon-hover-standard">
					<div class="comment-side-icon sno-side-icon sno-side-icon-">
				<div class="sno-side-icon-ring">
										<i class="fa fa-comments-o"></i>
				</div>
			</div>
							<div class="like-side-icon sno-side-icon sno-side-icon-" data-liked="0" data-remember="1" data-post="2242822" >
				<div class="sno-color-inverter" data-d541ad4b3cb8be589709631779fdcc58="7b65f0997086d4f6ebc2c8015d65cb55"></div>
				<div class="sno-side-icon-ring">
					<div class="sno-side-icon-bubble like-count-bubble like-count-display">
						1					</div>
					<i class="fas fa-thumbs-up"></i>
				</div>
			</div>
							<a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.torchonline.com%2Fculture%2F2022%2F04%2F19%2Fat-its-halfway-point-moon-knight-has-already-surpassed-expectations%2F" title="Share on Facebook" target="_blank">
				<div class="facebook-side-icon sno-side-icon sharing-mobile-hide sno-side-icon-">
					<div class="sno-side-icon-ring">
						<i class="fa fa-facebook-f"></i>
						<span class="icon-hidden-text">Share on Facebook</span>
					</div>
				</div>
			</a>
							<a class="modal-share" href="https://twitter.com/intent/tweet?text=At Its Halfway Point, “Moon Knight” Has Already Surpassed Expectations&amp;url=https%3A%2F%2Fwww.torchonline.com%2F%3Fp%3D2242822&amp;via=SJUTorch" title="Tweet This Story" target="_blank">
				<div class="twitter-side-icon sno-side-icon sharing-mobile-hide sno-side-icon-">
					<div class="sno-side-icon-ring">
						<i class="fa fa-twitter"></i>
						<span class="icon-hidden-text">Share on Twitter</span>
					</div>
				</div>
			</a>
							<a class="modal-share" href="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.torchonline.com%2Fculture%2F2022%2F04%2F19%2Fat-its-halfway-point-moon-knight-has-already-surpassed-expectations%2F&amp;media=https://www.torchonline.com/wp-content/uploads/2022/04/unnamed-5-5.png&amp;description=At+Its+Halfway+Point%2C+%E2%80%9CMoon+Knight%E2%80%9D+Has+Already+Surpassed+Expectations" title="Share on Pinterest" target="_blank">
				<div class="pinterest-side-icon sno-side-icon sharing-mobile-hide sno-side-icon-">
					<div class="sno-side-icon-ring">
						<i class="fa fa-pinterest"></i>
						<span class="icon-hidden-text">Share on Pinterest</span>
					</div>
				</div>
			</a>
									<a href="#" onclick="return false;" class="modal-share share-email sharing-mobile-hide" title="Email this Story">
				<div class="email-side-icon sno-side-icon sno-side-icon-" data-story-id="2242822">
					<div class="sno-side-icon-ring">
						<i class="fa fa-envelope"></i>
						<span class="icon-hidden-text">Share via Email</span>
					</div>
				</div>
			</a>
													<a rel="nofollow" href="//www.torchonline.com/culture/2022/04/19/at-its-halfway-point-moon-knight-has-already-surpassed-expectations/?print=true" title="Print this Story">
				<div class="print-side-icon sno-side-icon sharing-mobile-hide sno-side-icon-">
					<div class="sno-side-icon-ring">
						<i class="fa fa-print"></i>
						<span class="icon-hidden-text">Print</span>
					</div>
				</div>
			</a>
			</div>
	<div id="sno_hoversearch"><div class="sno-search-close"style="float:right;"><i class="fas fa-times"></i></div><div class="hover-search-area"><form method="get" id="searchform-alt" action="https://www.torchonline.com/">
											<label for="s-alt" class="assistive-text">Search</label>
											<input type="text" class="field" name="s" id="s-alt" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
											<input type="submit" class="submit" name="submit" id="searchsubmit-alt" value="Search" />
											<button type="submit" id="sno-hover-search-button" class="sno-submit-search sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
										</form></div></div><div id="sno_hoverbar"><div class="hoverheader"><div id="search-top"><div class="sno-search-button"><i class="fa fa-search"></i><span class="icon-hidden-text">Activate Search</span></div></div><div class="socialmedia"></div><div id="back-top"><a id="snotop" href="#top" title="Return to Top"><div class="sno-arrow-up"><i class="fa fa-arrow-up"></i><span class="icon-hidden-text">Scroll to Top</span></div></a></div><div class="lf_headerleft"><a href="https://www.torchonline.com"><div class="sno-home menu-icon dashicons dashicons-admin-home"><span class="icon-hidden-text">Home</span></div></a></div><div class="hover_title"><div class="hover_titletext">At Its Halfway Point, “Moon Knight” Has Already Surpassed Expectations</div><span id="progress-bar"><span id="progress-bar-color"></span></span></div></div><div class="clear"></div></div><div id="hoverbar_menu"><ul class="slidemenu mobile-menu"><li class="mobile-search"><form method="get" class="searchform-alt-left" action="https://www.torchonline.com/">
									<label for="s-alt-left-hoverbar" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left-hoverbar" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="mobile-menu"><ul id="menu-bottom-menu-2" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-211"><a href="https://www.torchonline.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2229873"><a href="https://www.torchonline.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-213"><a href="https://www.torchonline.com/category/features/">Features</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2229874"><a href="https://www.torchonline.com/category/culture/">Culture</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-212"><a href="https://www.torchonline.com/category/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2240753"><a href="https://mailchi.mp/1ee43caabca4/torchnewsletter">Torch Newsletter</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2241137"><a href="https://us4.campaign-archive.com/?u=587ed2c2543665372998dc9d7&#038;id=6f6e88ffe5">Courtside Magazine 2021-2022</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2239787"><a href="https://www.torchonline.com/category/coronavirus-st-johns/">coronavirus st. john&#8217;s</a></li>
</ul></div></ul></div><script type="text/javascript">
			jQuery(document).ready(function(){
				
				// disabling this feature when using new scrollToFix elements in header
				if( jQuery('.sno-header-row-stick').length ) return;
	
				function sharingIconsResize() {
					if (jQuery(window).width() < 850) {
						var socialwidth;
						var count = jQuery("#mobile-socialmedia .sharing-mobile-show").length;
						if (count != 0) {
							socialwidth = 100 / count;
							jQuery('#mobile-socialmedia .sharing-icon').width(socialwidth + '%');
						}
					} else {
						jQuery('#sno_hoverbar .sharing-icon').width('50px');
					}
				}
								
				jQuery('.sno-search-button').click(function() {
					jQuery('#sno_hoversearch').fadeToggle();
					jQuery('#sno_hoversearch').css({ top: '0' });
					jQuery('#s-alt').focus();
				});
				jQuery('.sno-search-close').click(function() {
					jQuery('#sno_hoversearch').fadeToggle();
					jQuery('#sno_hoversearch').css({ top: '-50px' });
				});
	
				var NavScrollTop		= jQuery(window).scrollTop();
	    		
	    		if( jQuery('.navbarwrap').length ) {
	    			var	TopNavOffset 		= jQuery('.navbarwrap').offset().top;
					var TopNavDistance		= (TopNavOffset - NavScrollTop);
	   	 		}
	   	 		if( jQuery('.subnavbarwrap').length ) {
		   	 		var	BottomNavOffset 	= jQuery('.subnavbarwrap').offset().top;
		   	 		var	BottomNavDistance	= (BottomNavOffset - NavScrollTop);
	   	 		}
	   	 		
	   	 		jQuery('#hoverbar_menu .mobile-menu').height( jQuery(window).height() - 50);
	   	 		
	   	 		var HoverOffset = 0, HoverOffset2 = 0;
					   	 		var HoverHeight = jQuery('#sno_hoverbar').outerHeight();
	   	 		var HoverHeight2 = jQuery('#sno_hoverbar').outerHeight();
	   	 		
					
				var CurrentScroll = 0;
				var WindowHeight = jQuery(document).height() - 100;
				if( jQuery('.footer').length ) WindowHeight -= jQuery('.footer').height();
				
				jQuery(window).scroll(function(event) {

					var NextScroll = jQuery(this).scrollTop();
	
					var ScrollPercent = (NextScroll / (WindowHeight - jQuery(window).height())) * 100;
										
					jQuery('#progress-bar-color').css({ width: ScrollPercent + '%'});
					jQuery('#hoverbar_menu').css({ top: jQuery('#sno_hoverbar').height() });
					
					var headerLocation = jQuery("#wrap").offset().top;
					if (NextScroll > CurrentScroll && jQuery(document).scrollTop() > headerLocation) {
						if (jQuery('#sno_hoverbar').is(":hidden")) {
							jQuery('#sno_hoverbar').show();
							jQuery('#sno_hoverbar').stop().animate({ top: '0' }, { duration: 300, queue: false });
								
															if( jQuery('.subnavbarwrap').length ) {	
									jQuery('.subnavbarwrap').stop().animate({ top: HoverHeight2 +'px'}, { duration: 300, queue: false });
								}
														
															var lpb = jQuery('.lf_headerleft').width();
																var rpb = 50 + jQuery('.socialmedia').width();
																	rpb += jQuery('#sno_hoverbar .sno-search-button').width();
																jQuery('#progress-bar').css({ left: lpb + 'px', right: rpb + 'px'})
								        			}
	
	
	        			
					} else if (NextScroll < CurrentScroll && jQuery(document).scrollTop() < ( headerLocation + 300 ) && jQuery('#sno_hoverbar').is(":visible")) {
						
							jQuery('#hoverbar_menu').hide();
							jQuery('.close-icon').hide();
							jQuery('.menu-icon').show();
							jQuery('#hoverbar_menu').hide();
							jQuery('#sno_hoverbar').stop().animate({
								top: '-50px'
								},300, function(){
									jQuery('#sno_hoverbar').hide();
								});
							if ( jQuery('.navbarwrap').length ) { jQuery('.navbarwrap').stop().animate({ top: HoverOffset + 'px'},300); }
							if ( jQuery('.subnavbarwrap').length ) { jQuery('.subnavbarwrap').stop().animate({ top: HoverOffset2 + 'px'},300); }
	
					}
				CurrentScroll = NextScroll;
				});
	
	
			});
	
		</script><div class='remodal-story-image' data-remodal-id='modal-photo' data-remodal-options='hashTracking: false, closeOnConfirm: false'><button data-remodal-action="close" class="remodal-close sno-overlay-close"><span class="icon-hidden-text">Close</span></button><div class="remodal-inner-container"></div></div><div class="remodal-share-story" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false"><button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button><div class="remodal-share-inner-container"></div></div>		<div id="sno-comments-side">
			<div class="sno-comments-wrap">
				<div id="sno-comments-header">
					<div class='fas fa-times comment-close-icon'></div>
					<div class="sno-comments-title"><h3>Comments (0)</h3></div>
				</div>
									<div class="sno-comments-policy">
						We love comments and feedback, but we ask that you please be respectful in your responses.					</div>
									<div class="clear"></div>
									<input class="comments-share-thoughts" type="text" placeholder="Share your thoughts..." name="comments-thoughts"/>
								<div class="comments-toggle">
					<span class="comments-all comments-toggle-active">All</span>
									<span class="comments-staff-picks">The Torch Picks</span>
													<span class="comments-reader-picks">Reader Picks</span>
									<span class="comments-sort" data-sort="newest">Sort: <span class="active-sort">Newest</span></span>
				</div>
									<div id="comments" class="comments-area default-max-width show-avatars">
		<div id="respond" class="comment-respond">
		<p id="reply-title" class="comment-reply-title"> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/culture/2022/04/19/at-its-halfway-point-moon-knight-has-already-surpassed-expectations/#respond" style="display:none;">Cancel reply</a></small></p><form action="https://www.torchonline.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><label for="comment">Comment <span class="required" aria-hidden="true">*</span></label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><div class="sno_spam_control"><label for="spam_stopper">Spam Control Field.</label><input type="text" name="sno_is_legit_comment" id="spam_stopper" value="SNO_Spam_Stopper"/><label for="sno-verification">Verification Field.</label><input type="text" name="sno-verification" class="sno-verification" id="sno-verification" value="ef08bcfc2d05ed2f1598646c717a1fdb7b65f0997086d4f6ebc2c8015d65cb55"/></div><input id="wp-remember" type="hidden" name="wp-remember" value="1" /><div class="sno-comment-id" data-81b44db4191f86bcabe92cae83ae0d3d="7b65f0997086d4f6ebc2c8015d65cb55"></div><p class="comment-form-author"><label for="author">Name <span class="required" aria-hidden="true">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required="required" /></p>
<p class="comment-form-email"><label for="email">Email <span class="required" aria-hidden="true">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required="required" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit Comment" /> <input type='hidden' name='comment_post_ID' value='2242822' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form>	</div><!-- #respond -->
	</div>							</div>
		</div>
		<script type='text/javascript' id='thickbox-js-extra'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.torchonline.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.torchonline.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105' id='thickbox-js'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-includes/js/comment-reply.min.js?ver=5.9.3' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.9' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/www.torchonline.com\/wp-json\/","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.5.6' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/Chart.js/3.5.0/chart.min.js?ver=1.0.0' id='chartsjs-main-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/chroma-js/2.1.0/chroma.min.js?ver=1.0.0' id='chroma-lib-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/d3/3.5.3/d3.min.js?ver=1.0.0' id='d3-lib-js'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/topojson/1.6.9/topojson.min.js?ver=1.0.0' id='topo-json-js'></script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/plugins/sno-infographics//assets/datamaps/datamaps.all.min.js?ver=1.0.0' id='datamap-main-js'></script>
<script type='text/javascript' id='sno-infographics-widget-script-js-extra'>
/* <![CDATA[ */
var sno_infographics_ajax_object = {"ajax_url":"https:\/\/www.torchonline.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/plugins/sno-infographics/assets/script/sno-infographics-widget.js?ver=0.2.7' id='sno-infographics-widget-script-js'></script>
<script type='text/javascript' src='https://code.jquery.com/ui/1.12.1/jquery-ui.js?ver=5.9.3' id='ui-js'></script>
<script type='text/javascript' id='sno-pdf-flipbook-plugin-script-js-extra'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/www.torchonline.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/plugins/sno-pdf-flipbook/assets/script/sno-pdf-flipbook-script.js?ver=1.0.5' id='sno-pdf-flipbook-plugin-script-js'></script>
<script type='text/javascript' id='sno-pdf-flipbook-turnjs-script-js-extra'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/www.torchonline.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/plugins/sno-pdf-flipbook/assets/script/turn.js?ver=1.0.0' id='sno-pdf-flipbook-turnjs-script-js'></script>
<script type='text/javascript' id='sno-pdf-flipbook-mousewheel-script-js-extra'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/www.torchonline.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/plugins/sno-pdf-flipbook/assets/script/jquery.mousewheel.min.js?ver=1.0.0' id='sno-pdf-flipbook-mousewheel-script-js'></script>
<script type='text/javascript' id='sno-pdf-flipbook-hash-script-js-extra'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/www.torchonline.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/plugins/sno-pdf-flipbook/assets/script/hash.js?ver=1.0.0' id='sno-pdf-flipbook-hash-script-js'></script>
<script type='text/javascript' id='sno-pdf-flipbook-modernizr-script-js-extra'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/www.torchonline.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/plugins/sno-pdf-flipbook/assets/script/modernizr.2.5.3.min.js?ver=1.0.0' id='sno-pdf-flipbook-modernizr-script-js'></script>
<script type='text/javascript' id='custom-widget-script-js-extra'>
/* <![CDATA[ */
var sno_polls_ajax_object = {"ajax_url":"https:\/\/www.torchonline.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/plugins/sno-polls/assets/script/sno-polls-widget.js?ver=0.0.6' id='custom-widget-script-js'></script>
<script type='text/javascript' id='custom-test-widget-script-js-extra'>
/* <![CDATA[ */
var sno_polls_ajax_object = {"ajax_url":"https:\/\/www.torchonline.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/plugins/sno-polls/assets/script/sno-polls-test-widget.js?ver=0.0.5' id='custom-test-widget-script-js'></script>
<script type='text/javascript' id='custom-quiz-widget-script-js-extra'>
/* <![CDATA[ */
var sno_polls_ajax_object = {"ajax_url":"https:\/\/www.torchonline.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/plugins/sno-polls/assets/script/sno-polls-quiz-widget.js?ver=0.0.3' id='custom-quiz-widget-script-js'></script>
<script type='text/javascript' id='wp-polls-js-extra'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.torchonline.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.torchonline.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.6' id='wp-polls-js'></script>
<div id='sno-pdf-flipbook-full'></div></div></body></html>